dev-util/autodia: revbump: EAPI=7, perl-module.eclass
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Thu, 17 Oct 2019 03:26:28 +0000 (05:26 +0200)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Thu, 17 Oct 2019 03:26:28 +0000 (05:26 +0200)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
dev-util/autodia/autodia-2.140.0-r2.ebuild [new file with mode: 0644]

diff --git a/dev-util/autodia/autodia-2.140.0-r2.ebuild b/dev-util/autodia/autodia-2.140.0-r2.ebuild
new file mode 100644 (file)
index 0000000..0798ccd
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_NAME=Autodia
+DIST_VERSION=2.14
+DIST_AUTHOR=TEEJAY
+inherit perl-module
+
+DESCRIPTION="Parses source code, XML or data and produces an XML document in Dia format"
+HOMEPAGE="http://www.aarontrevena.co.uk/opensource/autodia/ ${HOMEPAGE}"
+SRC_URI+=" mirror://gentoo/${DIST_NAME}-2.14-dbi.patch.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="graphviz test"
+
+RDEPEND="
+       dev-perl/Template-Toolkit
+       dev-perl/XML-Simple
+       graphviz? (
+               dev-perl/GraphViz
+       )
+"
+BDEPEND="${RDEPEND}
+       test? (
+               dev-perl/Test-Pod
+       )
+"
+
+PATCHES=( "${WORKDIR}"/${DIST_NAME}-2.14-dbi.patch )
+
+mydoc="DEVELOP"