dev-util/strace: Sync 5.6 ebuild with previous fix
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 9 Apr 2020 08:15:37 +0000 (10:15 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 9 Apr 2020 08:29:02 +0000 (10:29 +0200)
Package-Manager: Portage-2.3.97, Repoman-2.3.22
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
dev-util/strace/strace-5.6.ebuild

index 369df34c83005270364fcee2119d6374ecd3f81b..cf81c1cc50d4343fc89f825ee5f6b5b01feae6ad 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit flag-o-matic toolchain-funcs
+inherit autotools flag-o-matic toolchain-funcs
 
 if [[ ${PV} == "9999" ]] ; then
        EGIT_REPO_URI="https://github.com/strace/strace.git"
@@ -22,6 +22,9 @@ IUSE="aio perl static unwind elfutils"
 
 REQUIRED_USE="?? ( unwind elfutils )"
 
+BDEPEND="
+       virtual/pkgconfig
+"
 LIB_DEPEND="
        unwind? ( sys-libs/libunwind[static-libs(+)] )
        elfutils? ( dev-libs/elfutils[static-libs(+)] )
@@ -37,9 +40,15 @@ RDEPEND="
        perl? ( dev-lang/perl )
 "
 
+PATCHES=(
+       "${FILESDIR}/${PN}-5.5-static.patch"
+)
+
 src_prepare() {
        default
 
+       eautoreconf
+
        if [[ ! -e configure ]] ; then
                # git generation
                sed /autoreconf/d -i bootstrap || die
@@ -49,8 +58,6 @@ src_prepare() {
        fi
 
        filter-lfs-flags # configure handles this sanely
-       # Add -pthread since strace wants -lrt for timer_create, and -lrt uses -lpthread.
-       use static && append-ldflags -static -pthread
 
        export ac_cv_header_libaio_h=$(usex aio)
        use elibc_musl && export ac_cv_header_stdc=no
@@ -71,6 +78,7 @@ src_configure() {
        # Don't require mpers support on non-multilib systems. #649560
        local myeconfargs=(
                --enable-mpers=check
+               $(use_enable static)
                $(use_with unwind libunwind)
                $(use_with elfutils libdw)
        )