dev-ros/stereo_image_proc: Backport upstream patch to build with gcc6.
authorAlexis Ballier <aballier@gentoo.org>
Mon, 23 Jan 2017 12:18:39 +0000 (13:18 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 23 Jan 2017 12:28:11 +0000 (13:28 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-ros/stereo_image_proc/files/gcc6.patch [new file with mode: 0644]
dev-ros/stereo_image_proc/stereo_image_proc-1.12.19-r1.ebuild

diff --git a/dev-ros/stereo_image_proc/files/gcc6.patch b/dev-ros/stereo_image_proc/files/gcc6.patch
new file mode 100644 (file)
index 0000000..ee4dfda
--- /dev/null
@@ -0,0 +1,33 @@
+commit 6c2d65452bd5fe62723988a1a570789921900d59
+Author: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
+Date:   Fri Sep 30 15:39:47 2016 +0200
+
+    address gcc6 build error
+    
+    With gcc6, compiling fails with `stdlib.h: No such file or directory`,
+    as including '-isystem /usr/include' breaks with gcc6, cf.,
+    https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129.
+    
+    This commit addresses this issue for this package in the same way
+    it was addressed in various other ROS packages. A list of related
+    commits and pull requests is at:
+    
+      https://github.com/ros/rosdistro/issues/12783
+    
+    Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
+
+diff --git a/stereo_image_proc/CMakeLists.txt b/stereo_image_proc/CMakeLists.txt
+index b7127d2..e201436 100644
+--- a/stereo_image_proc/CMakeLists.txt
++++ b/stereo_image_proc/CMakeLists.txt
+@@ -16,9 +16,7 @@ catkin_package(
+ include_directories(include)
+ find_package(OpenCV REQUIRED)
+-include_directories(SYSTEM ${catkin_INCLUDE_DIRS}
+-                           ${OpenCV_INCLUDE_DIRS}
+-)
++include_directories(${catkin_INCLUDE_DIRS} ${OpenCV_INCLUDE_DIRS})
+ # Nodelet library
+ add_library(${PROJECT_NAME} src/libstereo_image_proc/processor.cpp src/nodelets/disparity.cpp src/nodelets/point_cloud2.cpp)
index a180aaa9d27af82f122a2b0b765d4d54e88f5d6a..b01571e9046792ea8c9df9def87e97a325310839 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -29,3 +29,4 @@ RDEPEND="
        dev-libs/boost:=[threads]
 "
 DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/gcc6.patch" )