net-proxy/3proxy: bump to 0.8.13
authorAlex Efros <powerman-asdf@yandex.ru>
Tue, 8 Oct 2019 23:18:34 +0000 (02:18 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Fri, 11 Oct 2019 13:48:01 +0000 (16:48 +0300)
Closes: https://bugs.gentoo.org/696178
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Aleksandr Efros <powerman-asdf@yandex.ru>
Closes: https://github.com/gentoo/gentoo/pull/13230
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
net-proxy/3proxy/3proxy-0.8.13.ebuild [new file with mode: 0644]
net-proxy/3proxy/Manifest

diff --git a/net-proxy/3proxy/3proxy-0.8.13.ebuild b/net-proxy/3proxy/3proxy-0.8.13.ebuild
new file mode 100644 (file)
index 0000000..5ebf606
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A really tiny cross-platform proxy servers set"
+HOMEPAGE="https://www.3proxy.ru/"
+SRC_URI="https://github.com/z3APA3A/3proxy/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~sparc ~x86"
+IUSE=""
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-0.8.12-gentoo.patch
+)
+
+DOCS=( README cfg )
+HTML_DOCS=( doc/html/. )
+
+src_prepare() {
+       default
+       cp Makefile.Linux Makefile || die
+}
+
+src_compile() {
+       emake CC="$(tc-getCC)" LN="$(tc-getCC)"
+}
+
+src_install() {
+       local x
+
+       pushd src >/dev/null || die
+       dobin 3proxy
+       for x in proxy socks ftppr pop3p tcppm udppm mycrypt dighosts icqpr smtpp; do
+               newbin ${x} ${PN}-${x}
+               [[ -f "${S}"/man/${x}.8 ]] && newman "${S}"/man/${x}.8 ${PN}-${x}.8
+       done
+       popd >/dev/null
+
+       doman man/3proxy*.[38]
+
+       einstalldocs
+}
index 3d99915e3f4ff47d84fe41b0d538e3e5097f25f1..ee244468567d4496f5f561cb3d7a120d0cd10fd4 100644 (file)
@@ -1,2 +1,3 @@
 DIST 3proxy-0.8.12.tar.gz 528990 BLAKE2B fb338c93e25fe4d03d626118f8c3ef52af7104599e11d535dfa572c4fb47d609da66f199406a3c6bb9739766163bb7b54b529f71d4d6ff637567f2f67d3a9ed1 SHA512 33412e89991055598e06210dbcd7b2f9ee6810753c8f40ada02f222def0a49047a90ff7f2efa6895bc4f8ad99193866c980de2e79464310a77cc8e63c8b9813d
+DIST 3proxy-0.8.13.tar.gz 529072 BLAKE2B 45b756bf1ddaaf560f4f35c88e78d24dbafa28c3144de5317d9f5177c51da85a2148a7db743a656ddf853325e18edbcb200b37ff02afae2f203c3bfab66e1b58 SHA512 94b4a2568917c1d720276e38050a13e144d3e92ff41edd02eeebac0a6c21e6a839a58ea7dcb3abc03370e0f18452c953cfd7ad15ebac87e66b78d94fa52fbd79
 DIST 3proxy-0.8.9.tar.gz 497006 BLAKE2B c57e98eb586dfacefd530e091fecbee274d8104698ca082b71ea0607294199cb7db63fc32787236b7e797c928a7ba4f7bafa3ef35551bef76aacfbdf1f259fff SHA512 35153882fec7077b05b23f9cea91443126a8a9faf9818915612e0739196a8bd1f00e0bcefb339a86bad10bb0c1b9891bd06847934787f4758ec55e6cc2e9e815