old
authorMike Frysinger <vapier@gentoo.org>
Sat, 9 Dec 2006 08:04:47 +0000 (08:04 +0000)
committerMike Frysinger <vapier@gentoo.org>
Sat, 9 Dec 2006 08:04:47 +0000 (08:04 +0000)
app-arch/gzip/files/digest-gzip-1.3.7 [deleted file]
app-arch/gzip/files/gzip-1.3.7-CVE-2006-4334-8.2.patch [deleted file]
app-arch/gzip/files/gzip-1.3.7-asm-execstack.patch [deleted file]
app-arch/gzip/files/gzip-1.3.7-install-symlinks.patch [deleted file]
app-arch/gzip/gzip-1.3.7.ebuild [deleted file]

diff --git a/app-arch/gzip/files/digest-gzip-1.3.7 b/app-arch/gzip/files/digest-gzip-1.3.7
deleted file mode 100644 (file)
index 1ee19e7..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 d6c7f79bc445fbd12136662623de7edf gzip-1.3.7.tar.gz 543619
-RMD160 71e48e6d6b6f98f426fef2e965e4a24d7018be60 gzip-1.3.7.tar.gz 543619
-SHA256 1e18a88d7188e59bdabe48a19c06ddd2ff3bfd20d9bc3360df27f7be722bac5a gzip-1.3.7.tar.gz 543619
diff --git a/app-arch/gzip/files/gzip-1.3.7-CVE-2006-4334-8.2.patch b/app-arch/gzip/files/gzip-1.3.7-CVE-2006-4334-8.2.patch
deleted file mode 100644 (file)
index 2387708..0000000
+++ /dev/null
@@ -1,171 +0,0 @@
-http://bugs.gentoo.org/145511
-
---- gzip-1.3.5/gzip.h
-+++ gzip-1.3.5/gzip.h
-@@ -198,6 +198,8 @@
- extern int to_stdout;      /* output to stdout (-c) */
- extern int save_orig_name; /* set if original name must be saved */
-+#define MIN(a,b) ((a) <= (b) ? (a) : (b))
-+
- #define get_byte()  (inptr < insize ? inbuf[inptr++] : fill_inbuf(0))
- #define try_byte()  (inptr < insize ? inbuf[inptr++] : fill_inbuf(1))
---- gzip-1.3.5/unlzh.c
-+++ gzip-1.3.5/unlzh.c
-@@ -149,13 +149,17 @@
-     unsigned i, k, len, ch, jutbits, avail, nextcode, mask;
-     for (i = 1; i <= 16; i++) count[i] = 0;
--    for (i = 0; i < (unsigned)nchar; i++) count[bitlen[i]]++;
-+    for (i = 0; i < (unsigned)nchar; i++) {
-+        if (bitlen[i] > 16)
-+        gzip_error("Bad table (case a)\n");
-+        else count[bitlen[i]]++;
-+    }
-     start[1] = 0;
-     for (i = 1; i <= 16; i++)
-       start[i + 1] = start[i] + (count[i] << (16 - i));
--    if ((start[17] & 0xffff) != 0)
--      gzip_error ("Bad table\n");
-+    if ((start[17] & 0xffff) != 0 || tablebits > 16) /* 16 for weight below */
-+      gzip_error ("Bad table (case b)\n");
-     jutbits = 16 - tablebits;
-     for (i = 1; i <= (unsigned)tablebits; i++) {
-@@ -169,8 +173,8 @@
-     i = start[tablebits + 1] >> jutbits;
-     if (i != 0) {
--      k = 1 << tablebits;
--      while (i != k) table[i++] = 0;
-+      k = MIN(1 << tablebits, DIST_BUFSIZE);
-+      while (i < k) table[i++] = 0;
-     }
-     avail = nchar;
-@@ -179,6 +183,7 @@
-       if ((len = bitlen[ch]) == 0) continue;
-       nextcode = start[len] + weight[len];
-       if (len <= (unsigned)tablebits) {
-+          nextcode = MIN(nextcode, DIST_BUFSIZE);
-           for (i = start[len]; i < nextcode; i++) table[i] = ch;
-       } else {
-           k = start[len];
-@@ -218,7 +223,7 @@
-       for (i = 0; i < 256; i++) pt_table[i] = c;
-     } else {
-       i = 0;
--      while (i < n) {
-+      while (i < MIN(n,NPT)) {
-           c = bitbuf >> (BITBUFSIZ - 3);
-           if (c == 7) {
-               mask = (unsigned) 1 << (BITBUFSIZ - 1 - 3);
-@@ -228,7 +233,7 @@
-           pt_len[i++] = c;
-           if (i == i_special) {
-               c = getbits(2);
--              while (--c >= 0) pt_len[i++] = 0;
-+              while (--c >= 0 && i < NPT) pt_len[i++] = 0;
-           }
-       }
-       while (i < nn) pt_len[i++] = 0;
-@@ -248,7 +253,7 @@
-       for (i = 0; i < 4096; i++) c_table[i] = c;
-     } else {
-       i = 0;
--      while (i < n) {
-+      while (i < MIN(n,NC)) {
-           c = pt_table[bitbuf >> (BITBUFSIZ - 8)];
-           if (c >= NT) {
-               mask = (unsigned) 1 << (BITBUFSIZ - 1 - 8);
-@@ -256,14 +261,14 @@
-                   if (bitbuf & mask) c = right[c];
-                   else               c = left [c];
-                   mask >>= 1;
--              } while (c >= NT);
-+              } while (c >= NT && (mask || c != left[c]));
-           }
-           fillbuf((int) pt_len[c]);
-           if (c <= 2) {
-               if      (c == 0) c = 1;
-               else if (c == 1) c = getbits(4) + 3;
-               else             c = getbits(CBIT) + 20;
--              while (--c >= 0) c_len[i++] = 0;
-+              while (--c >= 0 && i < NC) c_len[i++] = 0;
-           } else c_len[i++] = c - 2;
-       }
-       while (i < NC) c_len[i++] = 0;
-@@ -292,7 +297,7 @@
-           if (bitbuf & mask) j = right[j];
-           else               j = left [j];
-           mask >>= 1;
--      } while (j >= NC);
-+      } while (j >= NC && (mask || j != left[j]));
-     }
-     fillbuf((int) c_len[j]);
-     return j;
-@@ -309,7 +314,7 @@
-           if (bitbuf & mask) j = right[j];
-           else               j = left [j];
-           mask >>= 1;
--      } while (j >= NP);
-+      } while (j >= NP && (mask || j != left[j]));
-     }
-     fillbuf((int) pt_len[j]);
-     if (j != 0) j = ((unsigned) 1 << (j - 1)) + getbits((int) (j - 1));
-@@ -356,7 +361,7 @@
-     while (--j >= 0) {
-       buffer[r] = buffer[i];
-       i = (i + 1) & (DICSIZ - 1);
--      if (++r == count) return r;
-+      if (++r >= count) return r;
-     }
-     for ( ; ; ) {
-       c = decode_c();
-@@ -366,14 +371,14 @@
-       }
-       if (c <= UCHAR_MAX) {
-           buffer[r] = c;
--          if (++r == count) return r;
-+          if (++r >= count) return r;
-       } else {
-           j = c - (UCHAR_MAX + 1 - THRESHOLD);
-           i = (r - decode_p() - 1) & (DICSIZ - 1);
-           while (--j >= 0) {
-               buffer[r] = buffer[i];
-               i = (i + 1) & (DICSIZ - 1);
--              if (++r == count) return r;
-+              if (++r >= count) return r;
-           }
-       }
-     }
---- gzip-1.3.5/unpack.c
-+++ gzip-1.3.5/unpack.c
-@@ -13,7 +13,6 @@
- #include "gzip.h"
- #include "crypt.h"
--#define MIN(a,b) ((a) <= (b) ? (a) : (b))
- /* The arguments must not have side effects. */
- #define MAX_BITLEN 25
-@@ -133,7 +132,7 @@
-       /* Remember where the literals of this length start in literal[] : */
-       lit_base[len] = base;
-       /* And read the literals: */
--      for (n = leaves[len]; n > 0; n--) {
-+      for (n = leaves[len]; n > 0 && base < LITERALS; n--) {
-           literal[base++] = (uch)get_byte();
-       }
-     }
-@@ -169,7 +168,7 @@
-     prefixp = &prefix_len[1<<peek_bits];
-     for (len = 1; len <= peek_bits; len++) {
-       int prefixes = leaves[len] << (peek_bits-len); /* may be 0 */
--      while (prefixes--) *--prefixp = (uch)len;
-+      while (prefixes-- && prefixp > prefix_len) *--prefixp = (uch)len;
-     }
-     /* The length of all other codes is unknown: */
-     while (prefixp > prefix_len) *--prefixp = 0;
diff --git a/app-arch/gzip/files/gzip-1.3.7-asm-execstack.patch b/app-arch/gzip/files/gzip-1.3.7-asm-execstack.patch
deleted file mode 100644 (file)
index 91f3249..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-Ripped from Fedora.
-Include stack markings in the asm code so the final binary 
-isn't assumed to require executable markings.
---- gzip-1.3.7/lib/match.c
-+++ gzip-1.3.7/lib/match.c
-@@ -54,6 +54,9 @@
-       .globl  _match_init
-       .globl  _longest_match
-+      .section .note.GNU-stack, "", @progbits
-+      .previous
-+      
-       .text
- _match_init:
diff --git a/app-arch/gzip/files/gzip-1.3.7-install-symlinks.patch b/app-arch/gzip/files/gzip-1.3.7-install-symlinks.patch
deleted file mode 100644 (file)
index 7975f58..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
---- gzip-1.3.7/Makefile.in
-+++ gzip-1.3.7/Makefile.in
-@@ -916,15 +916,19 @@
-         transform='$(transform)'; \
-         test "X$$prog" = "X$$prog_ext" || \
-           transform="$$transform"';s/$$/$(EXEEXT)/'; \
--        source=$(DESTDIR)$(bindir)/`echo "$$prog"|sed "$$transform"`; \
-+        sourcebase=`echo "$$prog"|sed "$$transform"`; \
-+        source=$(DESTDIR)$(bindir)/$$sourcebase; \
-         for alias in $$aliases; do \
-           dest=$(DESTDIR)$(bindir)/`echo "$$alias"|sed "$$transform"`; \
-           (set -x; \
-            rm -f "$$dest" && \
-            case $@ in \
-            install-exec-hook) \
--             for ln in ln "$(LN_S)"; do \
--               $$ln "$$source" "$$dest" && break; \
-+             for ln in "$(LN_S)"; do \
-+               case $$ln in \
-+                 ln) $$ln "$$source" "$$dest" && break;; \
-+                 *) $$ln "$$sourcebase" "$$dest" && break;; \
-+               esac; \
-              done;; \
-            esac \
-           ) || exit; \
diff --git a/app-arch/gzip/gzip-1.3.7.ebuild b/app-arch/gzip/gzip-1.3.7.ebuild
deleted file mode 100644 (file)
index d7cdb4d..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/gzip-1.3.7.ebuild,v 1.1 2006/12/07 13:56:37 vapier Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Standard GNU compressor"
-HOMEPAGE="http://www.gnu.org/software/gzip/gzip.html"
-SRC_URI="ftp://alpha.gnu.org/gnu/gzip/${P}.tar.gz
-       mirror://gentoo/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="nls static pic"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
-       nls? ( sys-devel/gettext )"
-PROVIDE="virtual/gzip"
-
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-       #epatch "${FILESDIR}"/${PN}-1.3.7-CVE-2006-4334-8.2.patch
-       epatch "${FILESDIR}"/${PN}-1.3.5-znew-tempfile-2.patch
-       epatch "${FILESDIR}"/${PN}-1.3.7-asm-execstack.patch
-       #epatch "${FILESDIR}"/${PN}-1.3.5-rsync.patch
-       epatch "${FILESDIR}"/${PN}-1.3.5-alpha.patch
-       epatch "${FILESDIR}"/${PN}-1.3.7-install-symlinks.patch
-}
-
-src_compile() {
-       use static && append-flags -static
-       # avoid text relocation in gzip
-       use pic && export DEFS="NO_ASM"
-       econf $(use_enable nls) || die
-       emake || die
-}
-
-src_install() {
-       emake install DESTDIR="${D}" || die
-       dodoc ChangeLog NEWS README THANKS TODO
-       docinto txt
-       dodoc algorithm.doc gzip.doc
-
-       # keep most things in /usr, just the fun stuff in /
-       dodir /bin
-       mv "${D}"/usr/bin/{gunzip,gzip,zcat} "${D}"/bin/ || die
-       dosym /bin/gunzip /usr/bin/gunzip || die
-}