dev-python/regex: Version bump to 2017.04.05
authorManuel Rüger <mrueg@gentoo.org>
Fri, 7 Apr 2017 00:44:50 +0000 (02:44 +0200)
committerManuel Rüger <mrueg@gentoo.org>
Fri, 7 Apr 2017 00:44:50 +0000 (02:44 +0200)
Package-Manager: Portage-2.3.5, Repoman-2.3.2

dev-python/regex/Manifest
dev-python/regex/regex-2016.01.10.ebuild
dev-python/regex/regex-2017.04.05.ebuild [new file with mode: 0644]

index 3b264432b6391b1a13dc2eb7c3ac37d1ef6eec24..e7c147f60adc9a97785dc34df1b46d228bf15adf 100644 (file)
@@ -1,3 +1,4 @@
 DIST regex-2015.07.12.tar.gz 554160 SHA256 9a39618645ce8c707c2c1346a3eeef0e441a9084df0739a5fcfe32059f68ebe1 SHA512 3b8cfa029744d17f06c659e6357d3a4520817656da6dcfc6952bbdac01fec266e8832fab649000fc7a3dacab508e2ae462728c139cc4cac913c40e2ae34abf54 WHIRLPOOL 86f004c6d8533071ef938ba39cfe34f198dcc56ab75883f8b5f2bc2dfaa40abc46b0ed64aa873821c6cc4e694c424dd8a16d97c35a6a1fafa7d2f84e09c59adf
 DIST regex-2015.07.19.tar.gz 554541 SHA256 c1dc58206f458749040ba813ef65067d7018908cab4bb16f4f12d9c7631e48b7 SHA512 94845ae133e25bdc2bb6ee6093f38f7a9281a64cdf4e53817c80183a28d7d0e2173f16f048f29ba38b2b277fc974c46a2f7d3b2fe1a346bc5d35c5fa45cdac17 WHIRLPOOL 4b38bd745c43fa2832d93e20fb4066911c6a224a2d1b4c3afaf8f03dcdf6d8d39896b25843671e0ee6916257b428455f24bbd493222e1b7bfa67c0b2ab838d32
 DIST regex-2016.01.10.tar.gz 574017 SHA256 02a77606e3f4a0a16a2727ed8f067681635a56221e8fca863ff64b196d5d79e0 SHA512 4f4700ca746763f857449003d32d56b5aa8069e3b71b160e719633b0cf00f80efc0766d8e1e193977278f91bd3e73c87aab31bee23aec77557ac9b3652ff6a2f WHIRLPOOL 9d493c0695b5920dfa71d94636d9f2952cbd5db97f60ae68c30fdf81fdbdab05c4726a41dae036541de694ec1ca688acdb20eaa48e514865da26c9a9569e30a0
+DIST regex-2017.04.05.tar.gz 601638 SHA256 d811874ed669165fe1059a54f860db5c6ab5f48100bf4945d915fd2f877b2531 SHA512 4c3e440e11f57e2323892e10fbed7f2c89b35771fdc970164ba69bb154dde535f6edb51a0997c924eb776c61e5efd1d04001abd343110518a89b5b7bf148ae49 WHIRLPOOL 52f9f16312efb2f9a7c3d8995590fc240e4a4c8326db04eea4d45cfcf49e255d273ed78013f1736d35366e97adbdc8388816d24c955935a1ca941a09680f4435
index e682641366e1cbb20b166a9fcb5166c160177d37..ab37d93506bd899e658e3c945c760f94299dead5 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=5
 
-PYTHON_COMPAT=( python{2_7,3_{4,5}} pypy )
+PYTHON_COMPAT=( python{2_7,3_{4,5}} pypy pypy3 )
 
 inherit distutils-r1 flag-o-matic
 
diff --git a/dev-python/regex/regex-2017.04.05.ebuild b/dev-python/regex/regex-2017.04.05.ebuild
new file mode 100644 (file)
index 0000000..4057d97
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} pypy )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Alternative regular expression module to replace re"
+HOMEPAGE="https://bitbucket.org/mrabarnett/mrab-regex"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DOCS=( README docs/UnicodeProperties.txt )
+
+python_compile() {
+       if ! python_is_python3; then
+               local CFLAGS=${CFLAGS}
+               append-cflags -fno-strict-aliasing
+       fi
+       distutils-r1_python_compile
+}
+
+python_test() {
+       local msg="tests failed under ${EPYTHON}"
+       # https://bitbucket.org/mrabarnett/mrab-regex/issue/145/1-fail-in-testsuite-under-pypy
+       einfo "There is one trivial fail of test test_empty_array under pypy"
+
+       if python_is_python3; then
+               "${PYTHON}" Python3/test_regex.py || die $msg
+       else
+               "${PYTHON}" Python2/test_regex.py || die $msg
+       fi
+}
+
+python_install_all() {
+       local DOCS="${DOCS} docs/UnicodeProperties.txt"
+       use doc && local HTML_DOCS=( docs/Features.html )
+
+       distutils-r1_python_install_all
+}