dev-libs/efl: -fno-common temporary fix
authorJoonas Niilola <juippis@gentoo.org>
Tue, 5 May 2020 15:24:24 +0000 (18:24 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 5 May 2020 15:24:45 +0000 (18:24 +0300)
Closes: https://bugs.gentoo.org/707258
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-libs/efl/efl-1.24.0.ebuild

index 745ca8e21df70be5ee1e96abeec1d948e75a9648..2c2dcccfc5bc95b92acf0a0a91224c768012b901 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit meson xdg-utils
+inherit flag-o-matic meson xdg-utils
 
 DESCRIPTION="Enlightenment Foundation Libraries all-in-one package"
 HOMEPAGE="https://www.enlightenment.org"
@@ -244,6 +244,8 @@ src_configure() {
        fi
        emesonargs+=( -D lua-interpreter="${luaChoice}" )
 
+       append-cflags -fcommon
+
        meson_src_configure
 }