dev-python/pylibacl: Enable py3.8
authorMichał Górny <mgorny@gentoo.org>
Fri, 24 Jan 2020 08:02:56 +0000 (09:02 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 24 Jan 2020 19:18:41 +0000 (20:18 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pylibacl/pylibacl-0.5.3.ebuild

index 1a57be2ea0dd5953abfcaaa5bc9f106285b94901..fe492631df24050e1db73a4dffe63f9b394ddaa8 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
 
 inherit distutils-r1
 
@@ -23,7 +23,7 @@ DEPEND="${RDEPEND}
 S="${WORKDIR}/${PN}-${PN}-v${PV}"
 
 python_test() {
-       if ! "${PYTHON}" test/test_acls.py; then
+       if ! "${EPYTHON}" test/test_acls.py -v; then
                eerror
                eerror "If you got the following errors:"
                eerror "\"IOError: [Errno 95] Operation not supported\","