app-misc/leave: EAPI 6 bump.
authorPatrice Clement <monsieurp@gentoo.org>
Sat, 21 Oct 2017 16:49:30 +0000 (18:49 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Sat, 21 Oct 2017 16:51:58 +0000 (18:51 +0200)
Package-Manager: Portage-2.3.8, Repoman-2.3.3

app-misc/leave/files/leave-fix-makefile.diff
app-misc/leave/leave-20100918-r1.ebuild [new file with mode: 0644]

index efcb89eadea68fca8b6578531528321b9ad63ab0..772add57d6fb781f9d77bd44ffd7602a68ef37cc 100644 (file)
@@ -1,5 +1,5 @@
---- Makefile.orig      2004-10-16 23:04:50.144563171 -0400
-+++ Makefile   2004-10-16 23:57:27.639495962 -0400
+--- a/Makefile.orig    2004-10-16 23:04:50.144563171 -0400
++++ b/Makefile 2004-10-16 23:57:27.639495962 -0400
 @@ -2,5 +2,16 @@
  # $FreeBSD: /repoman/r/ncvs/src/usr.bin/leave/Makefile,v 1.5 2002/02/08 22:31:41 markm Exp $
  
diff --git a/app-misc/leave/leave-20100918-r1.ebuild b/app-misc/leave/leave-20100918-r1.ebuild
new file mode 100644 (file)
index 0000000..88f5086
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="FreeBSD command-line tool that reminds you when its time to leave"
+HOMEPAGE="http://www.freebsd.org/cgi/cvsweb.cgi/src/usr.bin/leave/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-fix-makefile.diff"
+)
+
+src_compile() {
+       cp -v "${FILESDIR}/README" . || die
+       emake \
+               CC="$(tc-getCC)" \
+               CFLAGS="${CFLAGS}" \
+               LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+       dobin "${PN}"
+       doman "${PN}.1"
+       einstalldocs
+}