Version bump.
authorTim Harder <radhermit@gentoo.org>
Fri, 14 Oct 2011 22:23:54 +0000 (22:23 +0000)
committerTim Harder <radhermit@gentoo.org>
Fri, 14 Oct 2011 22:23:54 +0000 (22:23 +0000)
Package-Manager: portage-2.2.0_alpha66/cvs/Linux x86_64

app-vim/gist/ChangeLog
app-vim/gist/gist-5.2.ebuild [new file with mode: 0644]
app-vim/slimv/ChangeLog
app-vim/slimv/slimv-0.9.1.ebuild [new file with mode: 0644]

index 4f3d312fb6b18bfdf6ecb1f38ac5f2e622f4067e..3bde3d6e7a3e75a9a6c870d25393784282dab85f 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for app-vim/gist
 # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/gist/ChangeLog,v 1.3 2011/09/19 06:14:45 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gist/ChangeLog,v 1.4 2011/10/14 22:21:54 radhermit Exp $
+
+*gist-5.2 (14 Oct 2011)
+
+  14 Oct 2011; Tim Harder <radhermit@gentoo.org> +gist-5.2.ebuild:
+  Version bump.
 
 *gist-5.1 (19 Sep 2011)
 
diff --git a/app-vim/gist/gist-5.2.ebuild b/app-vim/gist/gist-5.2.ebuild
new file mode 100644 (file)
index 0000000..493a91f
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gist/gist-5.2.ebuild,v 1.1 2011/10/14 22:21:54 radhermit Exp $
+
+EAPI=4
+
+inherit vim-plugin
+
+MY_PN="Gist"
+DESCRIPTION="vim plugin: interact with gists (gist.github.com)"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2423"
+SRC_URI="https://github.com/vim-scripts/${MY_PN}.vim/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-misc/curl
+       dev-vcs/git"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_unpack() {
+       unpack ${A}
+       mv *-${MY_PN}.vim-* "${S}"
+}
+
+src_prepare() {
+       # There's good documentation included with the script, but it's not
+       # in a helpfile. Since there's rather too much information to include
+       # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+       mkdir "${S}"/doc
+       sed -e '0,/"=\+$/d' -e '/" GetLatest.\+$/,9999d' -e 's/^" \?//' \
+               -e 's/\(File: \)\([^.]\+\)\.vim/\1*\2.txt*/' \
+               plugin/${PN}.vim \
+               > doc/${PN}.txt
+
+       rm README || die
+}
index 42cc418840f1b958da2eddb09edd03e47f72a1ff..9bdcd8d628b9dd45c750527e43633f1310cc0605 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for app-vim/slimv
 # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/slimv/ChangeLog,v 1.11 2011/10/10 08:34:49 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/slimv/ChangeLog,v 1.12 2011/10/14 22:23:54 radhermit Exp $
+
+*slimv-0.9.1 (14 Oct 2011)
+
+  14 Oct 2011; Tim Harder <radhermit@gentoo.org> +slimv-0.9.1.ebuild:
+  Version bump.
 
   10 Oct 2011; Tim Harder <radhermit@gentoo.org> slimv-0.8.6.ebuild,
   slimv-0.9.0.ebuild:
diff --git a/app-vim/slimv/slimv-0.9.1.ebuild b/app-vim/slimv/slimv-0.9.1.ebuild
new file mode 100644 (file)
index 0000000..431c2a8
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/slimv/slimv-0.9.1.ebuild,v 1.1 2011/10/14 22:23:54 radhermit Exp $
+
+EAPI=4
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: aid Lisp development by providing a SLIME-like Lisp and Clojure REPL"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2531"
+SRC_URI="https://github.com/vim-scripts/${PN}.vim/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )
+       >=dev-lang/python-2.4
+       || (
+               dev-lisp/clisp
+               dev-lang/clojure
+               dev-lisp/abcl
+               dev-lisp/clozurecl
+               dev-lisp/ecls
+               dev-lisp/sbcl
+       )"
+
+VIM_PLUGIN_HELPFILES="slimv.txt"
+
+src_unpack() {
+       unpack ${A}
+       mv *-${PN}.vim-* "${S}"
+}
+
+src_prepare() {
+       # Remove emacs related files
+       rm -r slime swank-clojure || die
+
+       rm README || die
+}