sys-devel/dev86: fix bad sed delimiter
authorBen Kohler <bkohler@gentoo.org>
Tue, 24 Mar 2020 12:53:09 +0000 (07:53 -0500)
committerBen Kohler <bkohler@gentoo.org>
Tue, 24 Mar 2020 13:31:32 +0000 (08:31 -0500)
Closes: https://bugs.gentoo.org/710974
Package-Manager: Portage-2.3.95, Repoman-2.3.21
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
sys-devel/dev86/dev86-0.16.21-r3.ebuild

index 35355a20312cc5a4098b0656d4324a28294d9390..25c40753bdacaf1ccab75b11aaf21c696782e49d 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -36,7 +36,7 @@ src_prepare() {
                        makefile.in || die
        fi
 
-       sed -i -e "s:-O2 -g:${CFLAGS}:" -e '/INEXE=/s:-s::' makefile.in || die
+       sed -i -e "s|-O2 -g|${CFLAGS}|" -e '/INEXE=/s:-s::' makefile.in || die
        sed -i -e "s:/lib/:/$(get_libdir)/:" bcc/bcc.c || die
        sed -i -e '/INSTALL_OPTS=/s:-s::' bin86/Makefile || die
        sed -i -e '/install -m 755 -s/s:-s::' dis88/Makefile || die