app-misc/media-player-info: 24 version bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 19 Apr 2020 15:05:26 +0000 (17:05 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 19 Apr 2020 15:05:48 +0000 (17:05 +0200)
Closes: https://bugs.gentoo.org/716232
Closes: https://bugs.gentoo.org/718234
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-misc/media-player-info/Manifest
app-misc/media-player-info/media-player-info-24.ebuild [new file with mode: 0644]

index 829d0544b5a6aaecd8b5e5fe902590732983cbda..b6b9a266ac973a4200606a6eb4df9cd4739e26aa 100644 (file)
@@ -1 +1,2 @@
 DIST media-player-info-23.tar.gz 100849 BLAKE2B c64e33cb92c7f7b3fd77dd165fa5d33e433d09fbf171aba8ded2a274a24a544a85b7c874552951be25fe266090a882305416908975409b7c294d9435378c465d SHA512 4555456945f6f8c2fb23c86f80dc61e8e5448f3c402ac685e7eccd2df9f7861cdd41da842b0917349f7d83200ef10c810eb8b75fa6d62829834fdbdb81560f04
+DIST media-player-info-24.tar.gz 90017 BLAKE2B 4b8dff7ebc910cdee986756d211f7cec0c08d5089bc5478360bcea3d24613118d3e2557633866345b1970a39a1de5ff10648ea71b7ae6ec7e7ae5635b6d46bc3 SHA512 b762f82280d7ddc3ecc4cf612f6fb3bf887c56a3ece7d9e4a45ebc7e750d71a20ba70dbff63c2b5abaae0f1c3e079545e95d8eff07ae25e27add09e92b2b1544
diff --git a/app-misc/media-player-info/media-player-info-24.ebuild b/app-misc/media-player-info/media-player-info-24.ebuild
new file mode 100644 (file)
index 0000000..308e9e6
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit python-any-r1
+
+DESCRIPTION="Repository of data files describing media player capabilities"
+HOMEPAGE="https://gitlab.freedesktop.org/media-player-info/media-player-info"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# Upstream commit d83dd01a0a1df6198ee08954da1c033b88a1004b
+RDEPEND=">=virtual/udev-208"
+DEPEND="${RDEPEND}
+       ${PYTHON_DEPS}
+       virtual/pkgconfig
+"
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+DOCS=( AUTHORS NEWS )
+
+pkg_postinst() {
+       # Run for /lib/udev/hwdb.d/20-usb-media-players.hwdb
+       udevadm hwdb --update --root="${ROOT}"
+       # Upstream commit 1fab57c209035f7e66198343074e9cee06718bda
+       if [[ ${ROOT} != "" ]] && [[ ${ROOT} != "/" ]]; then
+               return 0
+       fi
+       udevadm control --reload
+}