media-sound/lilypond: version bump to 2.19.56
authorTim Harder <radhermit@gentoo.org>
Wed, 1 Mar 2017 13:52:40 +0000 (08:52 -0500)
committerTim Harder <radhermit@gentoo.org>
Wed, 1 Mar 2017 13:54:06 +0000 (08:54 -0500)
media-sound/lilypond/Manifest
media-sound/lilypond/lilypond-2.19.56.ebuild [new file with mode: 0644]
media-sound/lilypond/lilypond-9999.ebuild

index 5b3b7ef93a6ac064f19ae2c9996731a4cbbb3d40..65444f5b328092eab0494ffec3b870b7e56b0d2a 100644 (file)
@@ -1,3 +1,4 @@
 DIST lilypond-2.18.2.tar.gz 16027977 SHA256 329d733765b0ba7be1878ae3f457dbbb875cc2840d2b75af4afc48c9454fba07 SHA512 0692f6eb41733076ba7f610cd1e65762f4dfd67307e2ab9e222b140d58ae3a1bb1c6b3be3bcff778d57f161868cf6d57e99bf43bf20f2663d042a07493942ec6 WHIRLPOOL 95db264992a1e425fd1ee53d980941eef554c1784a1adfc105750d82d11664f61207c2b1897b6e99448790131c0715f08401f45b663c420553925596c6fd4b1c
 DIST lilypond-2.19.54.tar.gz 17068093 SHA256 0ee709f1e58caf13cf5abea9bb74179ba5c7a4f2dc470ec48d9aefb553e68a58 SHA512 bcf682595017e5ad9125c3c8e89c00faa3ab7f84ac92dce06ac6ea1d93f358d779f83b2391e36219ea8f76fa569c9f3c17120024cca4cf43a0facb2b24127c8b WHIRLPOOL 7ce1cc7e89c5907515f8505a1e1efe1aadf8df48c24d70a2fe39924cf9301b6c676121e6c6ceac75b76a085e5d940c6c3bb6c31e87d314dda72c68f0af1307c8
 DIST lilypond-2.19.55.tar.gz 17138603 SHA256 fe39c2ce7ff5c1945e4bf96deffdf17fe962d681aa9aeb585e5691e301acb31b SHA512 4e3c8f408a3508bd6f82951a417aa67cbbcf11d9d77e128cb52512418d3f91df781ac07356ea96a1b60b67ce42c48ee7dcad44100ddf64584a6f4e0f58f1e0a5 WHIRLPOOL ef60cd6bd5043f5d22f97513e0c93a96ea6698bcf26ebadf204bf30ce19aed70bfb7114d158f23b36370543858bda44e7fb660f778ecd420fa9430801681c55c
+DIST lilypond-2.19.56.tar.gz 17157260 SHA256 71e53cb4a7c1fe33f383be1af186b40a9b42d81784f6fb5e605c29be5359265c SHA512 e56dc3dab2768d0056e2525d19ab9e2e0c74e781a2bc914ac910a4c85f770ef55561e6110386211025de34fa608d16988cc0a3ae398e8f347ac993013ef832af WHIRLPOOL a042048bea43ee2cfe49612b6ec1ae550d3abfa7e4ed0a62c0c805ac429340f2fa4979e1c3995aa516796aadf6135d2c714212d971a087bdb725fa6d89f8f567
diff --git a/media-sound/lilypond/lilypond-2.19.56.ebuild b/media-sound/lilypond/lilypond-2.19.56.ebuild
new file mode 100644 (file)
index 0000000..4b68761
--- /dev/null
@@ -0,0 +1,147 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+[[ "${PV}" = "9999" ]] && inherit git-r3
+inherit elisp-common autotools python-single-r1 xdg-utils
+
+if [[ "${PV}" = "9999" ]]; then
+       EGIT_REPO_URI="git://git.sv.gnu.org/lilypond.git"
+else
+       SRC_URI="http://download.linuxaudio.org/lilypond/sources/v${PV:0:4}/${P}.tar.gz"
+       KEYWORDS="~alpha ~amd64 ~arm ~hppa ~x86"
+fi
+
+DESCRIPTION="GNU Music Typesetter"
+HOMEPAGE="http://lilypond.org/"
+
+LICENSE="GPL-3 FDL-1.3"
+SLOT="0"
+LANGS=" ca cs da de el eo es fi fr it ja nl ru sv tr uk vi zh_TW"
+IUSE="debug emacs guile2 profile vim-syntax ${LANGS// / linguas_}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND=">=app-text/ghostscript-gpl-8.15
+       >=dev-scheme/guile-1.8.2:12[deprecated,regex]
+       media-fonts/tex-gyre
+       media-libs/fontconfig
+       media-libs/freetype:2
+       >=x11-libs/pango-1.12.3
+       emacs? ( virtual/emacs )
+       guile2? ( >=dev-scheme/guile-2:12 )
+       !guile2? (
+               >=dev-scheme/guile-1.8.2:12[deprecated,regex]
+               <dev-scheme/guile-2.0:12
+       )
+       ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+       app-text/t1utils
+       dev-lang/perl
+       dev-libs/kpathsea
+       >=dev-texlive/texlive-metapost-2013
+       || (
+               >=app-text/texlive-core-2013
+               >=dev-tex/metapost-1.803
+       )
+       virtual/pkgconfig
+       media-gfx/fontforge[png]
+       >=sys-apps/texinfo-4.11
+       >=sys-devel/bison-2.0
+       sys-devel/flex
+       sys-devel/gettext
+       sys-devel/make"
+
+# Correct output data for tests isn't bundled with releases
+RESTRICT="test"
+
+DOCS=( DEDICATION HACKING README.txt ROADMAP )
+
+pkg_setup() {
+       # make sure >=metapost-1.803 is selected if it's installed, bug 498704
+       if [[ ${MERGE_TYPE} != binary ]] && has_version ">=dev-tex/metapost-1.803" ; then
+               if [[ $(readlink "${EROOT}"/usr/bin/mpost) =~ mpost-texlive-* ]] ; then
+                       einfo "Updating metapost symlink"
+                       eselect mpost update || die
+               fi
+       fi
+
+       python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       default
+
+       if ! use vim-syntax ; then
+               sed -i 's/vim//' GNUmakefile.in || die
+       fi
+
+       # respect CFLAGS
+       sed -i 's/OPTIMIZE -g/OPTIMIZE/' aclocal.m4 || die
+
+       for lang in ${LANGS}; do
+               use linguas_${lang} || rm po/${lang}.po || die
+       done
+
+       # respect AR
+       sed -i "s/^AR=ar/AR=$(tc-getAR)/" stepmake/stepmake/library-vars.make || die
+
+       # remove bundled texinfo file (fixes bug #448560)
+       rm tex/texinfo.tex || die
+
+       eautoreconf
+
+       xdg_environment_reset #586592
+}
+
+src_configure() {
+       # documentation generation currently not supported since it requires a newer
+       # version of texi2html than is currently in the tree
+
+       local myeconfargs=(
+               --with-texgyre-dir=/usr/share/fonts/tex-gyre
+               --disable-documentation
+               --disable-optimising
+               --disable-pipe
+               $(use_enable debug debugging)
+               $(use_enable guile2)
+               $(use_enable profile profiling)
+       )
+
+       econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+       default
+
+       if use emacs ; then
+               elisp-compile elisp/lilypond-{font-lock,indent,mode,what-beat}.el \
+                       || die "elisp-compile failed"
+       fi
+}
+
+src_install () {
+       emake DESTDIR="${D}" vimdir=/usr/share/vim/vimfiles install
+
+       # remove elisp files since they are in the wrong directory
+       rm -r "${ED}"/usr/share/emacs || die
+
+       if use emacs ; then
+               elisp-install ${PN} elisp/*.{el,elc} elisp/out/*.el \
+                       || die "elisp-install failed"
+               elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el
+       fi
+
+       python_fix_shebang "${ED}"
+
+       einstalldocs
+}
+
+pkg_postinst() {
+       use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+       use emacs && elisp-site-regen
+}
index 07f46f515a194a940c702281e4ccefd0b38b5635..4b68761a09e03ac577edcfb40df58fea6cf43fc7 100644 (file)
@@ -99,7 +99,7 @@ src_configure() {
        # documentation generation currently not supported since it requires a newer
        # version of texi2html than is currently in the tree
 
-       local myeconfargs+=(
+       local myeconfargs=(
                --with-texgyre-dir=/usr/share/fonts/tex-gyre
                --disable-documentation
                --disable-optimising