gnome-base/libgnomekbd: bump to 3.26.1
authorRémi Cardona <remi@gentoo.org>
Thu, 7 Feb 2019 22:28:30 +0000 (23:28 +0100)
committerRémi Cardona <remi@gentoo.org>
Thu, 7 Feb 2019 22:30:37 +0000 (23:30 +0100)
Package-Manager: Portage-2.3.59, Repoman-2.3.12
Signed-off-by: Rémi Cardona <remi@gentoo.org>
gnome-base/libgnomekbd/Manifest
gnome-base/libgnomekbd/libgnomekbd-3.26.1.ebuild [new file with mode: 0644]

index 32646d436a46dfff0d6905c48e79c7f72cd735d2..024cd359945954953a2d1717143b8d74cc201618 100644 (file)
@@ -1 +1,2 @@
 DIST libgnomekbd-3.26.0.tar.xz 449204 BLAKE2B 360f6da6ea7ad2850ecba062e0825cadcbc62ab9fdd432ad1fd4f38d32230e9eb6da1b7eb50116302b39be76565da7554df2c96e3a348e5130c428158bfa7792 SHA512 dc3ee91468e570d038bc91c4458ddb49dc097639c671815eecc4308efea85e29c1121cfd959e62f970a2e8112f818296802be804e99b96ee89fd5de8136645d9
+DIST libgnomekbd-3.26.1.tar.xz 450636 BLAKE2B 241f2f9af95696600f82ab3a1f53f80c6e76f6e81636419407957f172a2758ee16f5c6d419ab1c1c37d2e054c42b65404062471eceabc0fba45099481eb7b214 SHA512 8e83522f4d96001f9635278a001e0208d6d37e74b19a8c1702ec6de651036ad37a03385e66adbd3bae01d845a9a6181bb76f45bffec31eac98d600b49ab4360c
diff --git a/gnome-base/libgnomekbd/libgnomekbd-3.26.1.ebuild b/gnome-base/libgnomekbd/libgnomekbd-3.26.1.ebuild
new file mode 100644 (file)
index 0000000..778e492
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2
+
+DESCRIPTION="Gnome keyboard configuration library"
+HOMEPAGE="https://www.gnome.org"
+
+LICENSE="LGPL-2+"
+SLOT="0/8"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="+introspection test"
+
+RDEPEND="
+       >=dev-libs/glib-2.18:2
+       >=x11-libs/gtk+-2.91.7:3[X,introspection?]
+       >=x11-libs/libxklavier-5.2[introspection?]
+
+       introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+DEPEND="${RDEPEND}
+       dev-util/glib-utils
+       >=sys-devel/gettext-0.19.4
+       virtual/pkgconfig
+"
+
+src_configure() {
+       gnome2_src_configure \
+               --disable-static \
+               $(use_enable introspection) \
+               $(use_enable test tests)
+}