dev-python/jellyfish: Drop 0.5.6
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 1 Jun 2019 14:29:23 +0000 (16:29 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 1 Jun 2019 14:30:16 +0000 (16:30 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.13
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-python/jellyfish/Manifest
dev-python/jellyfish/jellyfish-0.5.6.ebuild [deleted file]

index c47409de3199fb79ca1ddaf7a35c1260e542617e..cc79ad9cd5e462446226b4bb63081632cfd53012 100644 (file)
@@ -1,2 +1 @@
-DIST jellyfish-0.5.6.tar.gz 132177 BLAKE2B f5d3ac95c6057fc890705c7435c4d79ce81de4684cecea89001c00f785bc85c316587a85ffc5e3334d239d1ae6b375525924fcadb32d5159925d0217e488465a SHA512 12f09e877dd2a9386adc336a56c8ea6566179e5ba333045ad70604c17c288fa61fad2aa9735c76c58d69dfba95f99876e608e2d05995085f970834132fb8504f
 DIST jellyfish-0.7.1.tar.gz 131122 BLAKE2B c494e38d3101b1a7bfd295b80957d834bc3e475dac72bd9d81669466eb395e293faa41a581953250133d455d20ca71959414cabd73d5c3dea444ee39e4e8f973 SHA512 c8464171cead812f6dab8c61c74d83afafbf6451e7143e5be74400dffcf895be925a3628ac4fff47467b6dbf70b6d068daaf1c141b1846e53d5d19bed1617ca0
diff --git a/dev-python/jellyfish/jellyfish-0.5.6.ebuild b/dev-python/jellyfish/jellyfish-0.5.6.ebuild
deleted file mode 100644 (file)
index 9e60204..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-DISTUTILS_IN_SOURCE_BUILD=1
-
-inherit distutils-r1
-
-DESCRIPTION="Python module for doing approximate and phonetic matching of strings"
-HOMEPAGE="https://github.com/jamesturk/jellyfish https://pypi.org/project/jellyfish/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? (
-               dev-python/pytest-runner[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/unicodecsv[${PYTHON_USEDEP}]
-       )
-"
-
-python_compile() {
-       esetup.py build_ext --inplace
-       esetup.py build
-}
-
-python_compile_all() {
-       if use doc; then
-               esetup.py build_sphinx
-               HTML_DOCS=( build/sphinx/html/. )
-       fi
-}
-
-python_test() {
-       py.test jellyfish/test.py || die "tests failed with ${EPYTHON}"
-}