dev-haskell/gtk3: bump up to 0.14.9-r2
authorSergei Trofimovich <slyfox@gentoo.org>
Sat, 14 Dec 2019 21:54:40 +0000 (21:54 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Sat, 14 Dec 2019 22:53:41 +0000 (22:53 +0000)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-haskell/gtk3/Manifest
dev-haskell/gtk3/gtk3-0.14.9-r2.ebuild [new file with mode: 0644]

index 8a8a287dec413ecf450af070ff80af44014a9a06..55cb495552e536b22e15d02d42435535740ec475 100644 (file)
@@ -1,2 +1,3 @@
 DIST gtk3-0.13.7.tar.gz 673031 BLAKE2B 4a99b1c430cad1d940b9c30cbf4ab2bcddf64d2bdcc645b2ad37c86069a4817c677ccc3552007c9aeb41755125650cea19c70786dd4a64d348bf483bd08a3073 SHA512 c350ae55a7044684e6f2d94592decfcd01d3e96900a468cd417bad52713502c89c328f96cd4ff29647169a76287b8dada9654d46c4dc884c0dab0590ad57762e
 DIST gtk3-0.14.6.tar.gz 675439 BLAKE2B 7b5699db78f68e763ba972c2a82aa4044d2b97e60137443732b199afb2b611758130b9dcc8240da7492d0853c8bbdc88aa9e18884798eb1c33d7f6af7fbd9409 SHA512 d03930164fa117ebd6bcc79b79a9cfc0449c5ed0b3de6999f26ad63673a67a146f989245efa68b4e1484091689b350a5df95ed49bbbe9d4a30fbe418cbb37209
+DIST gtk3-0.14.9.tar.gz 676542 BLAKE2B d2aeec5fd59dfe71e6c62e6abf60370f12ca8d7a3d3716593151a2f7697e8b53bbf4e8c094df1a2162703422cfb390407c8a83b564fed78c16f94d3d07036122 SHA512 aaf2a257c74f5b0a569d0e61aef535e2f0c8158feb34bed523c7aff31cf155098f93d3a88ba49bea906ae669bf63fb0486f4c747a620c2199c2e7859486e7270
diff --git a/dev-haskell/gtk3/gtk3-0.14.9-r2.ebuild b/dev-haskell/gtk3/gtk3-0.14.9-r2.ebuild
new file mode 100644 (file)
index 0000000..17c84fb
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.5.5.9999
+#hackport: flags: have-gio:gio,build-demos:examples
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the Gtk+ 3 graphical user interface library"
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+fmode-binary +gio"
+
+RDEPEND=">=dev-haskell/cairo-0.13.0.0:=[profile?] <dev-haskell/cairo-0.14:=[profile?]
+       >=dev-haskell/glib-0.13.0.0:=[profile?] <dev-haskell/glib-0.14:=[profile?]
+       dev-haskell/mtl:=[profile?]
+       >=dev-haskell/pango-0.13.0.0:=[profile?] <dev-haskell/pango-0.14:=[profile?]
+       >=dev-haskell/text-0.11.0.6:=[profile?] <dev-haskell/text-1.3:=[profile?]
+       >=dev-lang/ghc-7.4.1:=
+       dev-libs/glib:2
+       x11-libs/gtk+:3
+       gio? ( >=dev-haskell/gio-0.13.0:=[profile?] <dev-haskell/gio-0.14:=[profile?] )
+"
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.24 <dev-haskell/cabal-3.1
+       >=dev-haskell/gtk2hs-buildtools-0.13.2.0 <dev-haskell/gtk2hs-buildtools-0.14
+       virtual/pkgconfig
+"
+
+src_prepare() {
+       default
+
+       cabal_chdeps \
+               'Cabal >= 1.24 && < 2.3' 'Cabal >= 1.24 && < 3.1'
+}
+
+src_configure() {
+       haskell-cabal_src_configure \
+               $(cabal_flag fmode-binary fmode-binary) \
+               $(cabal_flag gio have-gio)
+}