app-emulation/xen-tools: bump to 4.11.2-r1
authorTomas Mozes <hydrapolic@gmail.com>
Thu, 31 Oct 2019 19:37:51 +0000 (19:37 +0000)
committerThomas Deutschmann <whissi@gentoo.org>
Thu, 31 Oct 2019 21:48:12 +0000 (22:48 +0100)
Bug: https://bugs.gentoo.org/699048
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com>
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
app-emulation/xen-tools/Manifest
app-emulation/xen-tools/xen-tools-4.11.2-r1.ebuild [new file with mode: 0644]

index 8b872b4ad6f57b8b0ac4b9aafeb88d5404152480..f0ec2ef4d9dc8691547043ff902e9a0471c39698 100644 (file)
@@ -4,6 +4,7 @@ DIST ipxe-git-d2063b7693e0e35db97b2264aa987eb6341ae779.tar.gz 3792227 BLAKE2B 72
 DIST seabios-1.12.0.tar.gz 613542 BLAKE2B f145c2db716996bfa9e5c014086ccfaa8ae96ebc158f34303b122b7bf209408c567665d8691364df8d8e886f63e0e72a3f3cd319dfa86ef581023201b5d94e53 SHA512 e52c5363e5bb37b5286e55545aa06bd126218f9d0e3a06ac2e189de68fe3de3256c11ca1bb13357a9c384d7e3af6284083ff3aa587688b5de04ef11b97bdfa27
 DIST seabios-rel-1.11.1.tar.gz 604125 BLAKE2B df2b7322f5169fb74e7f5dd3f680e7d8ad3e6f93e8b1376d15bbda8865458648a0d6086011a8a6549e7ad1794844878736441e70067580c0eb416e20ee038d95 SHA512 69622460475b54ba77a10509dae0ef46d9c733c6c8527ab56a4f2298534dcf1f7722eb501df873ab612222e5867e334c2831cc4c95dd23771aee10740acf0273
 DIST xen-4.11.2-upstream-patches-0.tar.xz 11532 BLAKE2B e36509d6256ac4018f20711baba77619a7c3a684d81e25a94cffba9c9f53ec9e0efdcefcd6a7ffa26b49fd3d4e0dfc2126f1ea620f0bd35ea83188b4587e5b38 SHA512 4a97d1e56cb3e5152372f0c0b99f8838194b2e03ed1255e87611d8bb28af9c9199fe123d3542f5ba9b3f652c29a519b5e4255b8925c0c8dfbd588f83ed8806d9
+DIST xen-4.11.2-upstream-patches-1.tar.xz 77556 BLAKE2B f95af370f8a99a27bfc762e661364da6f1ef1b08dd5a6b81a5421d32bcad820097a694c5656e174cec7ed53ff140f80d63f57ac31867edf12e68ef4d87ea8b44 SHA512 f41f2ff20648eed76918c865958d42b99d2743188514c63e27797c80e9169f7f5843ac48195e38d269d02edcb9889f042b992b85773ca61c267282e41ea8dae6
 DIST xen-4.11.2.tar.gz 25164925 BLAKE2B 11adea16d93235af5807e6e3784e0fc36ce34f274a85d1976a5c8ad36a323437216b0cf6bb6cb13b00e1e838e319a9f8f4b9c417870eef9ed660f22274d81310 SHA512 48d3d926d35eb56c79c06d0abc6e6be2564fadb43367cc7f46881c669a75016707672179c2cca1c4cfb14af2cefd46e2e7f99470cddf7df2886d8435a2de814e
 DIST xen-4.12.1-upstream-patches-0.tar.xz 18520 BLAKE2B b7a3f51e7629d2cabf9a8363291a7178b4f9a3eed7907271939a21e8058900d4497405c7d06df4ec71a558d68998456ca3c79d431dee2ec39fe21a9280fc2d4b SHA512 f15192505803de6cc1f1eb04b653f186ac7b08afa9575ee0b57f793f77cc08b10945c1b849183763a5b40d6ee6a80eab37d97219f3fff7a76397088cb6854b08
 DIST xen-4.12.1.tar.gz 26970584 BLAKE2B ceab2af3d36b72d838d7b4f58f6855c97cf05282a4ea3c82eda29b8945ee20563845b7be02884bf0a061a633fb2b3016a2f7396ce34d9b3d93f90d6ee6d449ed SHA512 be15d3af6b109771aaf59b3621e4e1560b7d9a963d9b7f6a1f6f4a1c907fd97434b060c15f75849b44fbda33f26eb51b030d14d068c6ad5103ad240fe7a98f40
diff --git a/app-emulation/xen-tools/xen-tools-4.11.2-r1.ebuild b/app-emulation/xen-tools/xen-tools-4.11.2-r1.ebuild
new file mode 100644 (file)
index 0000000..11c24de
--- /dev/null
@@ -0,0 +1,460 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='ncurses,xml,threads'
+
+inherit bash-completion-r1 flag-o-matic multilib python-single-r1 toolchain-funcs
+
+MY_PV=${PV/_/-}
+
+if [[ $PV == *9999 ]]; then
+       inherit git-r3
+       REPO="xen.git"
+       EGIT_REPO_URI="git://xenbits.xen.org/${REPO}"
+       S="${WORKDIR}/${REPO}"
+else
+       KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+       UPSTREAM_VER=1
+       SECURITY_VER=
+       # xen-tools's gentoo patches tarball
+       GENTOO_VER=19
+       # xen-tools's gentoo patches version which apply to this specific ebuild
+       GENTOO_GPV=0
+       # xen-tools ovmf's patches
+       OVMF_VER=
+
+       SEABIOS_VER=1.11.1
+       EDK2_COMMIT=ef529e6ab7c31290a33045bb1f1837447cc0eb56
+
+       [[ -n ${UPSTREAM_VER} ]] && \
+               UPSTREAM_PATCHSET_URI="https://dev.gentoo.org/~dlan/distfiles/${P/-tools/}-upstream-patches-${UPSTREAM_VER}.tar.xz
+               https://github.com/hydrapolic/gentoo-dist/raw/master/xen/${P/-tools/}-upstream-patches-${UPSTREAM_VER}.tar.xz"
+       [[ -n ${SECURITY_VER} ]] && \
+               SECURITY_PATCHSET_URI="https://dev.gentoo.org/~dlan/distfiles/${PN/-tools}-security-patches-${SECURITY_VER}.tar.xz"
+       [[ -n ${GENTOO_VER} ]] && \
+               GENTOO_PATCHSET_URI="https://dev.gentoo.org/~dlan/distfiles/${PN/-tools}-gentoo-patches-${GENTOO_VER}.tar.xz
+               https://github.com/hydrapolic/gentoo-dist/raw/master/xen/${PN/-tools/}-gentoo-patches-${GENTOO_VER}.tar.xz"
+       [[ -n ${OVMF_VER} ]] && \
+               OVMF_PATCHSET_URI="https://dev.gentoo.org/~dlan/distfiles/${PN/-tools}-ovmf-patches-${OVMF_VER}.tar.xz"
+
+       SRC_URI="https://downloads.xenproject.org/release/xen/${MY_PV}/xen-${MY_PV}.tar.gz
+       https://git.seabios.org/cgit/seabios.git/snapshot/seabios-rel-${SEABIOS_VER}.tar.gz
+       ovmf? ( https://github.com/tianocore/edk2/archive/${EDK2_COMMIT}.tar.gz -> edk2-${EDK2_COMMIT}.tar.gz
+               ${OVMF_PATCHSET_URI} )
+       ${UPSTREAM_PATCHSET_URI}
+       ${SECURITY_PATCHSET_URI}
+       ${GENTOO_PATCHSET_URI}"
+
+       S="${WORKDIR}/xen-${MY_PV}"
+fi
+
+DESCRIPTION="Xen tools including QEMU and xl"
+HOMEPAGE="https://www.xenproject.org"
+DOCS=( README docs/README.xen-bugtool )
+
+LICENSE="GPL-2"
+SLOT="0/$(ver_cut 1-2)"
+# Inclusion of IUSE ocaml on stabalizing requires maintainer of ocaml to (get off his hands and) make
+# >=dev-lang/ocaml-4 stable
+# Masked in profiles/eapi-5-files instead
+IUSE="api debug doc flask +hvm ocaml ovmf +pam pygrub python +qemu +qemu-traditional screen sdl static-libs system-qemu system-seabios"
+
+REQUIRED_USE="
+       ${PYTHON_REQUIRED_USE}
+       ovmf? ( hvm )
+       pygrub? ( python )
+       ?? ( qemu system-qemu )"
+
+COMMON_DEPEND="
+       sys-apps/pciutils
+       dev-libs/lzo:2
+       dev-libs/glib:2
+       dev-libs/yajl
+       dev-libs/libaio
+       dev-libs/libgcrypt:0
+       sys-libs/zlib
+       ${PYTHON_DEPS}
+"
+
+DEPEND="${COMMON_DEPEND}
+       >=sys-kernel/linux-headers-4.11
+       dev-python/lxml[${PYTHON_USEDEP}]
+       x86? ( sys-devel/dev86
+               sys-firmware/ipxe[qemu]
+               sys-power/iasl )
+       pam? ( dev-python/pypam[${PYTHON_USEDEP}] )
+       api? ( dev-libs/libxml2
+               net-misc/curl )
+       ovmf? (
+               !arm? ( !arm64? ( dev-lang/nasm ) )
+               $(python_gen_impl_dep sqlite)
+               )
+       !amd64? ( >=sys-apps/dtc-1.4.0 )
+       amd64? ( sys-devel/bin86
+               sys-devel/dev86
+               sys-firmware/ipxe[qemu]
+               sys-power/iasl
+               system-seabios? ( sys-firmware/seabios ) )
+       dev-lang/perl
+       app-misc/pax-utils
+       doc? (
+               app-text/ghostscript-gpl
+               app-text/pandoc
+               dev-python/markdown[${PYTHON_USEDEP}]
+               dev-texlive/texlive-latexextra
+               media-gfx/transfig
+       )
+       hvm? ( x11-base/xorg-proto )
+       qemu? (
+               app-arch/snappy:=
+               x11-libs/pixman
+               sdl? ( media-libs/libsdl[X] )
+       )
+       system-qemu? ( app-emulation/qemu[xen] )
+       ocaml? ( dev-ml/findlib
+               >=dev-lang/ocaml-4 )"
+
+RDEPEND="${COMMON_DEPEND}
+       sys-apps/iproute2[-minimal]
+       net-misc/bridge-utils
+       screen? (
+               app-misc/screen
+               app-admin/logrotate
+       )"
+
+# hvmloader is used to bootstrap a fully virtualized kernel
+# Approved by QA team in bug #144032
+QA_WX_LOAD="
+       usr/libexec/xen/boot/hvmloader
+       usr/share/qemu-xen/qemu/s390-ccw.img
+       usr/share/qemu-xen/qemu/u-boot.e500
+"
+
+QA_PREBUILT="
+       usr/libexec/xen/bin/ivshmem-client
+       usr/libexec/xen/bin/ivshmem-server
+       usr/libexec/xen/bin/qemu-img
+       usr/libexec/xen/bin/qemu-io
+       usr/libexec/xen/bin/qemu-keymap
+       usr/libexec/xen/bin/qemu-nbd
+       usr/libexec/xen/bin/qemu-pr-helper
+       usr/libexec/xen/bin/qemu-system-i386
+       usr/libexec/xen/bin/virtfs-proxy-helper
+       usr/libexec/xen/libexec/xen-bridge-helper
+       usr/share/qemu-xen/qemu/s390-ccw.img
+       usr/share/qemu-xen/qemu/s390-netboot.img
+       usr/share/qemu-xen/qemu/u-boot.e500
+"
+
+RESTRICT="test"
+
+pkg_setup() {
+       python_setup
+       export "CONFIG_LOMOUNT=y"
+
+       #bug 522642, disable compile tools/tests
+       export "CONFIG_TESTS=n"
+
+       if [[ -z ${XEN_TARGET_ARCH} ]] ; then
+               if use x86 && use amd64; then
+                       die "Confusion! Both x86 and amd64 are set in your use flags!"
+               elif use x86; then
+                       export XEN_TARGET_ARCH="x86_32"
+               elif use amd64 ; then
+                       export XEN_TARGET_ARCH="x86_64"
+               elif use arm; then
+                       export XEN_TARGET_ARCH="arm32"
+               elif use arm64; then
+                       export XEN_TARGET_ARCH="arm64"
+               else
+                       die "Unsupported architecture!"
+               fi
+       fi
+}
+
+src_prepare() {
+       local i
+
+       # Upstream's patchset
+       if [[ -n ${UPSTREAM_VER} ]]; then
+               einfo "Try to apply Xen Upstream patch set"
+               eapply "${WORKDIR}"/patches-upstream
+       fi
+
+       # Security patchset
+       if [[ -n ${SECURITY_VER} ]]; then
+       einfo "Try to apply Xen Security patch set"
+               # apply main xen patches
+               # Two parallel systems, both work side by side
+               # Over time they may concdense into one. This will suffice for now
+               EPATCH_SUFFIX="patch"
+               EPATCH_FORCE="yes"
+
+               source "${WORKDIR}"/patches-security/${PV}.conf || die
+
+               for i in ${XEN_SECURITY_MAIN}; do
+                       eapply "${WORKDIR}"/patches-security/xen/$i
+               done
+
+               # apply qemu-xen/upstream patches
+               pushd "${S}"/tools/qemu-xen/ > /dev/null
+               for i in ${XEN_SECURITY_QEMUU}; do
+                       eapply "${WORKDIR}"/patches-security/qemuu/$i
+               done
+               popd > /dev/null
+
+               # apply qemu-traditional patches
+               pushd "${S}"/tools/qemu-xen-traditional/ > /dev/null
+               for i in ${XEN_SECURITY_QEMUT}; do
+                       eapply "${WORKDIR}"/patches-security/qemut/$i
+               done
+               popd > /dev/null
+       fi
+
+       # move before Gentoo patch, one patch should apply to seabios, to fix gcc-4.5.x build err
+       mv ../seabios-rel-${SEABIOS_VER} tools/firmware/seabios-dir-remote || die
+       pushd tools/firmware/ > /dev/null
+       ln -s seabios-dir-remote seabios-dir || die
+       popd > /dev/null
+
+       # Gentoo's patchset
+       if [[ -n ${GENTOO_VER} && -n ${GENTOO_GPV} ]]; then
+               einfo "Try to apply Gentoo specific patch set"
+               source "${FILESDIR}"/gentoo-patches.conf || die
+               _gpv=_gpv_${PN/-/_}_${PV//./}_${GENTOO_GPV}
+               for i in ${!_gpv}; do
+                       eapply "${WORKDIR}"/patches-gentoo/$i
+               done
+       fi
+
+       # Ovmf's patchset
+       if use ovmf; then
+               if [[ -n ${OVMF_VER} ]];then
+                       einfo "Try to apply Ovmf patch set"
+                       pushd "${WORKDIR}"/edk2-*/ > /dev/null
+                       eapply "${WORKDIR}"/patches-ovmf
+                       popd > /dev/null
+               fi
+               mv ../edk2-${EDK2_COMMIT} tools/firmware/ovmf-dir-remote || die
+               cp tools/firmware/ovmf-makefile tools/firmware/ovmf-dir-remote/Makefile || die
+       fi
+
+       mv tools/qemu-xen/qemu-bridge-helper.c tools/qemu-xen/xen-bridge-helper.c || die
+
+       # Fix texi2html build error with new texi2html, qemu.doc.html
+       sed -i -e "/texi2html -monolithic/s/-number//" tools/qemu-xen-traditional/Makefile || die
+
+       use api || sed -e "/SUBDIRS-\$(LIBXENAPI_BINDINGS) += libxen/d" -i tools/Makefile || die
+       sed -e 's:$(MAKE) PYTHON=$(PYTHON) subdirs-$@:LC_ALL=C "$(MAKE)" PYTHON=$(PYTHON) subdirs-$@:' \
+               -i tools/firmware/Makefile || die
+
+       # Drop .config, fixes to gcc-4.6
+       sed -e '/-include $(XEN_ROOT)\/.config/d' -i Config.mk || die "Couldn't drop"
+
+       # drop flags
+       unset CFLAGS
+       unset LDFLAGS
+       unset ASFLAGS
+       unset CPPFLAGS
+
+       if ! use pygrub; then
+               sed -e '/^SUBDIRS-y += pygrub/d' -i tools/Makefile || die
+       fi
+
+       if ! use python; then
+               sed -e '/^SUBDIRS-y += python$/d' -i tools/Makefile || die
+       fi
+
+       if ! use hvm; then
+               sed -e '/SUBDIRS-$(CONFIG_X86) += firmware/d' -i tools/Makefile || die
+       # Bug 351648
+       elif ! use x86 && ! has x86 $(get_all_abis); then
+               mkdir -p "${WORKDIR}"/extra-headers/gnu || die
+               touch "${WORKDIR}"/extra-headers/gnu/stubs-32.h || die
+               export CPATH="${WORKDIR}"/extra-headers
+       fi
+
+       if use qemu; then
+               if use sdl; then
+                       sed -i -e "s:\$\$source/configure:\0 --enable-sdl:" \
+                               tools/Makefile || die
+               else
+                       sed -i -e "s:\${QEMU_ROOT\:\-\.}/configure:\0 --disable-sdl:" \
+                               tools/qemu-xen-traditional/xen-setup || die
+                       sed -i -e "s:\$\$source/configure:\0 --disable-sdl:" \
+                               tools/Makefile || die
+               fi
+       else
+               # Don't bother with qemu, only needed for fully virtualised guests
+               sed -e "s:install-tools\: tools/qemu-xen-traditional-dir:install-tools\: :g" -i Makefile || die
+       fi
+
+       # Reset bash completion dir; Bug 472438
+       sed -e "s:^BASH_COMPLETION_DIR ?= \$(CONFIG_DIR)/bash_completion.d:BASH_COMPLETION_DIR ?= $(get_bashcompdir):" \
+               -i Config.mk || die
+       sed -i -e "/bash-completion/s/xl\.sh/xl/g" tools/libxl/Makefile || die
+
+       # xencommons, Bug #492332, sed lighter weight than patching
+       sed -e 's:\$QEMU_XEN -xen-domid:test -e "\$QEMU_XEN" \&\& &:' \
+               -i tools/hotplug/Linux/init.d/xencommons.in || die
+
+       # fix bashishm
+       sed -e '/Usage/s/\$//g' \
+               -i tools/hotplug/Linux/init.d/xendriverdomain.in || die
+
+       # respect multilib, usr/lib/libcacard.so.0.0.0
+       sed -e "/^libdir=/s/\/lib/\/$(get_libdir)/" \
+               -i tools/qemu-xen/configure || die
+
+       #bug 518136, don't build 32bit exactuable for nomultilib profile
+       if [[ "${ARCH}" == 'amd64' ]] && ! has_multilib_profile; then
+               sed -i -e "/x86_emulator/d" tools/tests/Makefile || die
+       fi
+
+       # uncomment lines in xl.conf
+       sed -e 's:^#autoballoon=:autoballoon=:' \
+               -e 's:^#lockfile=:lockfile=:' \
+               -e 's:^#vif.default.script=:vif.default.script=:' \
+               -i tools/examples/xl.conf  || die
+
+       # disable capstone (Bug #673474)
+       sed -e "s:\$\$source/configure:\0 --disable-capstone:" \
+               -i tools/Makefile || die
+
+       # disable glusterfs
+       sed -e "s:\$\$source/configure:\0 --disable-glusterfs:" \
+               -i tools/Makefile || die
+
+       default
+}
+
+src_configure() {
+       local myconf="--prefix=${PREFIX}/usr \
+               --libdir=${PREFIX}/usr/$(get_libdir) \
+               --libexecdir=${PREFIX}/usr/libexec \
+               --localstatedir=${EPREFIX}/var \
+               --disable-werror \
+               --disable-xen \
+               --enable-tools \
+               --enable-docs \
+               $(use_enable api xenapi) \
+               $(use_enable pam) \
+               $(use_enable ocaml ocamltools) \
+               $(use_enable ovmf) \
+               --with-xenstored=$(usex ocaml 'oxenstored' 'xenstored') \
+               "
+
+       use system-seabios && myconf+=" --with-system-seabios=/usr/share/seabios/bios.bin"
+       use system-qemu && myconf+=" --with-system-qemu=/usr/bin/qemu-system-x86_64"
+       use amd64 && myconf+=" $(use_enable qemu-traditional)"
+       tc-ld-disable-gold # Bug 669570
+       econf ${myconf}
+}
+
+src_compile() {
+       local myopt
+       use debug && myopt="${myopt} debug=y"
+
+       if test-flag-CC -fno-strict-overflow; then
+               append-flags -fno-strict-overflow
+       fi
+
+       emake CC="$(tc-getCC)" LD="$(tc-getLD)" AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" build-tools ${myopt}
+
+       if use doc; then
+               emake -C docs build
+       else
+               emake -C docs man-pages
+       fi
+}
+
+src_install() {
+       # Override auto-detection in the build system, bug #382573
+       export INITD_DIR=/tmp/init.d
+       export CONFIG_LEAF_DIR=../tmp/default
+
+       # Let the build system compile installed Python modules.
+       local PYTHONDONTWRITEBYTECODE
+       export PYTHONDONTWRITEBYTECODE
+
+       emake DESTDIR="${ED}" DOCDIR="/usr/share/doc/${PF}" \
+               XEN_PYTHON_NATIVE_INSTALL=y install-tools
+
+       # Created at runtime
+       rm -rv "${ED}/var/run" || die
+
+       # Fix the remaining Python shebangs.
+       python_fix_shebang "${D}"
+
+       # Remove RedHat-specific stuff
+       rm -rf "${D}/tmp" || die
+
+       if use doc; then
+               emake DESTDIR="${D}" DOCDIR="/usr/share/doc/${PF}" install-docs
+               dodoc -r docs/{pdf,txt}
+       else
+               emake -C docs DESTDIR="${D}" DOCDIR="/usr/share/doc/${PF}" install-man-pages # Bug 668032
+       fi
+       dodoc ${DOCS[@]}
+
+       newconfd "${FILESDIR}"/xendomains.confd xendomains
+       newconfd "${FILESDIR}"/xenstored.confd xenstored
+       newconfd "${FILESDIR}"/xenconsoled.confd xenconsoled
+       newinitd "${FILESDIR}"/xendomains.initd-r2 xendomains
+       newinitd "${FILESDIR}"/xenstored.initd-r1 xenstored
+       newinitd "${FILESDIR}"/xenconsoled.initd xenconsoled
+       newinitd "${FILESDIR}"/xencommons.initd xencommons
+       newconfd "${FILESDIR}"/xencommons.confd xencommons
+       newinitd "${FILESDIR}"/xenqemudev.initd xenqemudev
+       newconfd "${FILESDIR}"/xenqemudev.confd xenqemudev
+       newinitd "${FILESDIR}"/xen-watchdog.initd xen-watchdog
+
+       if use screen; then
+               cat "${FILESDIR}"/xendomains-screen.confd >> "${D}"/etc/conf.d/xendomains || die
+               cp "${FILESDIR}"/xen-consoles.logrotate "${D}"/etc/xen/ || die
+               keepdir /var/log/xen-consoles
+       fi
+
+       # For -static-libs wrt Bug 384355
+       if ! use static-libs; then
+               rm -f "${D}"/usr/$(get_libdir)/*.a "${D}"/usr/$(get_libdir)/ocaml/*/*.a
+       fi
+
+       # for xendomains
+       keepdir /etc/xen/auto
+
+       # Remove files failing QA AFTER emake installs them, avoiding seeking absent files
+       find "${D}" \( -name openbios-sparc32 -o -name openbios-sparc64 \
+               -o -name openbios-ppc -o -name palcode-clipper \) -delete || die
+
+       keepdir /var/lib/xen/dump
+       keepdir /var/lib/xen/xenpaging
+       keepdir /var/lib/xenstored
+       keepdir /var/log/xen
+}
+
+pkg_postinst() {
+       elog "Official Xen Guide and the offical wiki page:"
+       elog "https://wiki.gentoo.org/wiki/Xen"
+       elog "https://wiki.xen.org/wiki/Main_Page"
+       elog ""
+       elog "Recommended to utilise the xencommons script to config system at boot"
+       elog "Add by use of rc-update on completion of the install"
+
+       if ! use hvm; then
+               echo
+               elog "HVM (VT-x and AMD-V) support has been disabled. If you need hvm"
+               elog "support enable the hvm use flag."
+               elog "An x86 or amd64 system is required to build HVM support."
+       fi
+
+       if use qemu; then
+               elog "The qemu-bridge-helper is renamed to the xen-bridge-helper in the in source"
+               elog "build of qemu.  This allows for app-emulation/qemu to be emerged concurrently"
+               elog "with the qemu capable xen.  It is up to the user to distinguish between and utilise"
+               elog "the qemu-bridge-helper and the xen-bridge-helper. File bugs of any issues that arise"
+       fi
+}