dev-util/cucumber: drop unused rubyzip:0 dependency, bug 611384
authorHans de Graaff <graaff@gentoo.org>
Sun, 2 Apr 2017 06:17:49 +0000 (08:17 +0200)
committerHans de Graaff <graaff@gentoo.org>
Sun, 2 Apr 2017 06:22:45 +0000 (08:22 +0200)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-util/cucumber/cucumber-1.3.17.ebuild
dev-util/cucumber/cucumber-1.3.20-r1.ebuild

index beb6bc09881ce4b51372561e6adbdbcf52cbd785..ed981e017f16eddc09160c6945eb9e7c0327d603 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -30,7 +30,6 @@ ruby_add_bdepend "
                >=dev-ruby/json-1.7
                dev-ruby/bundler
                >=dev-util/cucumber-1.3
-               dev-ruby/rubyzip:0
        )"
 
 ruby_add_rdepend "
index 2b555a4d19c8999a0e07cf03eb5f43e7c68fa1a8..77ea993fe079257f6dad1f71b0f02438f0bb2a4f 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -30,7 +30,6 @@ ruby_add_bdepend "
                >=dev-ruby/json-1.7
                dev-ruby/bundler
                >=dev-util/cucumber-1.3
-               dev-ruby/rubyzip:0
        )"
 
 ruby_add_rdepend "
@@ -49,7 +48,7 @@ all_ruby_prepare() {
        # Fix too-strict test dependencies
        sed -e '/nokogiri/ s/~> 1.5.2/>= 1.5.2/' \
                -e '/aruba/ s/= 0.5.2/~> 0.5/' \
-               -e '/rake/ s/10.2/10.5/' -i ${RUBY_FAKEGEM_GEMSPEC} || die
+               -e '/rake/ s/10.2/13/' -i ${RUBY_FAKEGEM_GEMSPEC} || die
 
        # Make sure spork is run in the right interpreter
        sed -i -e 's/#{Spork::BINARY}/-S #{Spork::BINARY}/' features/support/env.rb || die