dev-java/guava: Raise {jre,jdk} reqs to 1.7. Drop ppc64. Fixes bug 560042.
authorPatrice Clement <monsieurp@gentoo.org>
Thu, 10 Sep 2015 16:44:57 +0000 (16:44 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Thu, 10 Sep 2015 16:46:39 +0000 (16:46 +0000)
Package-Manager: portage-2.2.18
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
dev-java/guava/guava-13.0.1-r2.ebuild [new file with mode: 0644]

diff --git a/dev-java/guava/guava-13.0.1-r2.ebuild b/dev-java/guava/guava-13.0.1-r2.ebuild
new file mode 100644 (file)
index 0000000..2d8d471
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A collection of Google's core Java libraries"
+HOMEPAGE="https://code.google.com/p/guava-libraries/"
+SRC_URI="http://search.maven.org/remotecontent?filepath=com/google/${PN}/${PN}/${PV}/${P}-sources.jar"
+
+LICENSE="Apache-2.0"
+SLOT="13"
+KEYWORDS="~amd64 ~x86 ~ppc ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+
+CDEPEND="
+       dev-java/jsr305:0
+       java-virtuals/jdk-with-com-sun:0"
+RDEPEND="${CDEPEND}
+       >=virtual/jre-1.7"
+DEPEND="${CDEPEND}
+       app-arch/unzip
+       >=virtual/jdk-1.7"
+
+JAVA_GENTOO_CLASSPATH="jsr305"