sys-kernel/bliss-kernel-bin: adding new package
authorJonathan Vasquez <fearedbliss@gentoo.org>
Thu, 13 Feb 2020 02:03:40 +0000 (21:03 -0500)
committerJonathan Vasquez <fearedbliss@gentoo.org>
Thu, 13 Feb 2020 02:05:55 +0000 (21:05 -0500)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Jonathan Vasquez <fearedbliss@gentoo.org>
sys-kernel/bliss-kernel-bin/Manifest [new file with mode: 0644]
sys-kernel/bliss-kernel-bin/bliss-kernel-bin-4.14.170.ebuild [new file with mode: 0644]
sys-kernel/bliss-kernel-bin/bliss-kernel-bin-5.4.15.ebuild [new file with mode: 0644]
sys-kernel/bliss-kernel-bin/bliss-kernel-bin-5.5.2.ebuild [new file with mode: 0644]
sys-kernel/bliss-kernel-bin/metadata.xml [new file with mode: 0644]
virtual/linux-sources/linux-sources-3-r4.ebuild

diff --git a/sys-kernel/bliss-kernel-bin/Manifest b/sys-kernel/bliss-kernel-bin/Manifest
new file mode 100644 (file)
index 0000000..8797242
--- /dev/null
@@ -0,0 +1,3 @@
+DIST kernel-4.14.170-FC.01.tar.xz 94162352 BLAKE2B 360a6095c9ddaca171a1754c1989c4d382340d54fae4406aa1dde75c87ec2c8dd1e8772dd516db69d2fe8173ec4a7d0d2d6cb23517852be5f7f08dfad2213b28 SHA512 ba3888ab9f946dfc6b9a2536aab24d4ce304ff141f96754832b2d97f88aa7a7913530619e096fa55fd257a5f9ef0787b700d325a2bd28f6c65c1f33d9ce23b64
+DIST kernel-5.4.15-FC.01.tar.xz 117954936 BLAKE2B 96868fb485869dbb02120b84037847bf374eca12e281c7349ef9b3598e226dc2e7fe85f5e5f811f2c682ca4466e97f0dbae81c99912a7dc32c9302f76c46cc0e SHA512 8dcdd8c483a5f5d68cec94d3336b8b5cb8abda53c51f4539f7e89e4a9e47081cdc427ac81ff2ec9a5e1aedd9757951e876211cb6d6cd1b793026ac110d384de4
+DIST kernel-5.5.2-FC.01.tar.xz 118548744 BLAKE2B 001cd7728215c6654e88e7d22a8b2c4d30691e8c2960dc544713b3e53917fb34b02da1c2501d902e712b8f7bf7974cdf05f4431c8fe58878288c1852bb4010be SHA512 42feb156953efa09040bcd2a203e55d03a7d0889d64bbbe062e58c0edc70c9eaa6842eded2ff35bb53eb93e08eeae8233c913afc62376cbc6fce0a91290a0abf
diff --git a/sys-kernel/bliss-kernel-bin/bliss-kernel-bin-4.14.170.ebuild b/sys-kernel/bliss-kernel-bin/bliss-kernel-bin-4.14.170.ebuild
new file mode 100644 (file)
index 0000000..7df4e7a
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kernel-install
+
+# Variables
+_LV="FC.01"                     # Local Version
+_PLV="${PV}-${_LV}"             # Package Version + Local Version (Module Dir)
+
+# Main
+DESCRIPTION="Precompiled Vanilla Kernel (Kernel Ready-to-Eat [KRE])"
+HOMEPAGE="https://wiki.gentoo.org/wiki/User:Fearedbliss"
+SRC_URI="https://xyinn.org/gentoo/kernels/${_PLV}/kernel-${_PLV}.tar.xz"
+
+RESTRICT="strip test"
+LICENSE="GPL-2"
+SLOT="${_PLV}"
+KEYWORDS="-* ~amd64"
+
+# Unset 'initramfs' since 'bliss-kernel' doesn't need them
+# as an explicitly enabled IUSE from the kernel-install eclass.
+IUSE="-initramfs"
+
+S="${WORKDIR}"
+QA_PREBUILT="*"
+
+src_install() {
+       mv * "${ED}" || die
+}
+
+pkg_postinst() {
+       # Stub out this function. The downloaded tarball is ready to be installed
+       # into the OS directly.
+       debug-print-function ${FUNCNAME} "${@}"
+}
diff --git a/sys-kernel/bliss-kernel-bin/bliss-kernel-bin-5.4.15.ebuild b/sys-kernel/bliss-kernel-bin/bliss-kernel-bin-5.4.15.ebuild
new file mode 100644 (file)
index 0000000..7df4e7a
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kernel-install
+
+# Variables
+_LV="FC.01"                     # Local Version
+_PLV="${PV}-${_LV}"             # Package Version + Local Version (Module Dir)
+
+# Main
+DESCRIPTION="Precompiled Vanilla Kernel (Kernel Ready-to-Eat [KRE])"
+HOMEPAGE="https://wiki.gentoo.org/wiki/User:Fearedbliss"
+SRC_URI="https://xyinn.org/gentoo/kernels/${_PLV}/kernel-${_PLV}.tar.xz"
+
+RESTRICT="strip test"
+LICENSE="GPL-2"
+SLOT="${_PLV}"
+KEYWORDS="-* ~amd64"
+
+# Unset 'initramfs' since 'bliss-kernel' doesn't need them
+# as an explicitly enabled IUSE from the kernel-install eclass.
+IUSE="-initramfs"
+
+S="${WORKDIR}"
+QA_PREBUILT="*"
+
+src_install() {
+       mv * "${ED}" || die
+}
+
+pkg_postinst() {
+       # Stub out this function. The downloaded tarball is ready to be installed
+       # into the OS directly.
+       debug-print-function ${FUNCNAME} "${@}"
+}
diff --git a/sys-kernel/bliss-kernel-bin/bliss-kernel-bin-5.5.2.ebuild b/sys-kernel/bliss-kernel-bin/bliss-kernel-bin-5.5.2.ebuild
new file mode 100644 (file)
index 0000000..7df4e7a
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kernel-install
+
+# Variables
+_LV="FC.01"                     # Local Version
+_PLV="${PV}-${_LV}"             # Package Version + Local Version (Module Dir)
+
+# Main
+DESCRIPTION="Precompiled Vanilla Kernel (Kernel Ready-to-Eat [KRE])"
+HOMEPAGE="https://wiki.gentoo.org/wiki/User:Fearedbliss"
+SRC_URI="https://xyinn.org/gentoo/kernels/${_PLV}/kernel-${_PLV}.tar.xz"
+
+RESTRICT="strip test"
+LICENSE="GPL-2"
+SLOT="${_PLV}"
+KEYWORDS="-* ~amd64"
+
+# Unset 'initramfs' since 'bliss-kernel' doesn't need them
+# as an explicitly enabled IUSE from the kernel-install eclass.
+IUSE="-initramfs"
+
+S="${WORKDIR}"
+QA_PREBUILT="*"
+
+src_install() {
+       mv * "${ED}" || die
+}
+
+pkg_postinst() {
+       # Stub out this function. The downloaded tarball is ready to be installed
+       # into the OS directly.
+       debug-print-function ${FUNCNAME} "${@}"
+}
diff --git a/sys-kernel/bliss-kernel-bin/metadata.xml b/sys-kernel/bliss-kernel-bin/metadata.xml
new file mode 100644 (file)
index 0000000..f56f258
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+    <maintainer type="person">
+        <email>fearedbliss@gentoo.org</email>
+        <name>Jonathan Vasquez</name>
+    </maintainer>
+    <use>
+        <flag name='initramfs'>Build initramfs along with the kernel.</flag>
+    </use>
+</pkgmetadata>
index 7abf09d80f53b79df2faf850a3ffc7d7fff10210..046bf562bda5ecb475c1a56f56b4642f9f477e28 100644 (file)
@@ -27,4 +27,5 @@ RDEPEND="
                sys-kernel/gentoo-kernel-bin
                sys-kernel/vanilla-kernel
                sys-kernel/vanilla-kernel-bin
+               sys-kernel/bliss-kernel-bin
        )"