net-im/mcabber: version bump, fixes bug #608800 / CVE-2017-5604
authorWolfram Schlich <wschlich@gentoo.org>
Thu, 16 Feb 2017 16:19:15 +0000 (17:19 +0100)
committerWolfram Schlich <wschlich@gentoo.org>
Thu, 16 Feb 2017 16:19:15 +0000 (17:19 +0100)
Package-Manager: portage-2.3.3

net-im/mcabber/Manifest
net-im/mcabber/mcabber-1.0.5.ebuild [new file with mode: 0644]

index 49a5b8c06b053d36bfe45d925c3a483ae4853ead..6c5207c514fce176fddeeb92212895f45fde6b6e 100644 (file)
@@ -1 +1,2 @@
 DIST mcabber-1.0.4.tar.bz2 605462 SHA256 63b6bc003fcceba4dc4b273ed1c71643c4f8d95e8696543d53f64a7672b1ce0a SHA512 f4f85abcdfa341489e47ba5290e9cce79cdd749753155003e3a9b5edd145e158c91d0a32fe07983196be5729134279f21fbe94511a41b98b793b415157b6b15b WHIRLPOOL 09f7d6e53e352a0e7087da0ddb1a9f5a717c447c2e7a3d9d3e1b14409e8dd4e95472a60af743a0fbb64d4ee296b8eb6654cfb3ce6030ea8abd95ba863eacb7f1
+DIST mcabber-1.0.5.tar.bz2 605483 SHA256 a0f200817d2b6196fe4d37918ce16f6fed83a3cef861d7165161e8b1cafcad47 SHA512 81b67899245902f495af7b44a5a0d710db69da731a00fb9ed84bdc0f88d5dc662f340817b1eaa843802c95105846234743eba52117f18bf12dd37a0da61d414d WHIRLPOOL ee09cc76d6e6f8507f6e78ed9f9d9f512f841d36d35d707593c15b9f0b3c9e1bc8910d1e0ff1cdf5ff6c34781a75eb7b1fd447789ba9a36f5137d8bf12dbacbe
diff --git a/net-im/mcabber/mcabber-1.0.5.ebuild b/net-im/mcabber/mcabber-1.0.5.ebuild
new file mode 100644 (file)
index 0000000..7bf75fb
--- /dev/null
@@ -0,0 +1,116 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic autotools-utils
+
+DESCRIPTION="A small Jabber console client with various features, like MUC, SSL, PGP"
+HOMEPAGE="http://mcabber.com/"
+#REV="a18e1b488f1c"
+#SRC_URI="http://mcabber.com/hg/index.cgi/archive/${REV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="http://mcabber.com/files/${P}.tar.bz2"
+
+#S=${WORKDIR}/${PN}-${REV}/${PN}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+IUSE="aspell crypt idn modules otr spell ssl vim-syntax"
+
+LANGS="cs de fr it nl pl ru uk"
+# localized help versions are installed only, when LINGUAS var is set
+for i in ${LANGS}; do
+       IUSE="${IUSE} linguas_${i}"
+done;
+
+RDEPEND="crypt? ( >=app-crypt/gpgme-1.0.0 )
+       otr? ( >=net-libs/libotr-3.1.0 )
+       aspell? ( app-text/aspell )
+       vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
+       idn? ( net-dns/libidn  )
+       spell? ( app-text/enchant )
+       dev-libs/glib:2
+       sys-libs/ncurses:0=
+       >=net-libs/loudmouth-1.4.3-r1[ssl?]"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+## autotools-utils.eclass settings
+AUTOTOOLS_AUTORECONF="1"
+AUTOTOOLS_IN_SOURCE_BUILD="1"
+DOCS=( AUTHORS ChangeLog NEWS README TODO mcabberrc.example doc/README_PGP.txt )
+
+pkg_setup() {
+       if use aspell && use spell; then
+               ewarn "NOTE: You have both USE flags 'aspell' and 'spell' enabled, enchant (USE flag 'spell') will be preferred."
+       fi
+}
+
+src_configure() {
+       local myeconfargs=(
+               $(use_enable crypt gpgme) \
+               $(use_enable otr) \
+               $(use_enable aspell) \
+               $(use_enable spell enchant) \
+               $(use_enable modules) \
+               $(use_with idn libidn)
+       )
+       autotools-utils_src_configure
+}
+
+src_install() {
+       autotools-utils_src_install
+
+       # clean unneeded language documentation
+       for i in ${LANGS}; do
+               use linguas_${i} || rm -rf "${ED}"/usr/share/${PN}/help/${i}
+       done
+
+       # contrib themes
+       insinto /usr/share/${PN}/themes
+       doins "${S}"/contrib/themes/*
+
+       # contrib generic scripts
+       exeinto /usr/share/${PN}/scripts
+       doexe "${S}"/contrib/*.{pl,py}
+
+       # contrib event scripts
+       exeinto /usr/share/${PN}/scripts/events
+       doexe "${S}"/contrib/events/*
+
+       if use vim-syntax; then
+               cd contrib/vim/ || die
+
+               insinto /usr/share/vim/vimfiles/syntax
+               doins mcabber_log-syntax.vim
+
+               insinto /usr/share/vim/vimfiles/ftdetect
+               doins mcabber_log-ftdetect.vim
+       fi
+}
+
+pkg_postinst() {
+       elog
+       elog "MCabber requires you to create a subdirectory .mcabber in your home"
+       elog "directory and to place a configuration file there."
+       elog "An example mcabberrc was installed as part of the documentation."
+       elog "To create a new mcabberrc based on the example mcabberrc, execute the"
+       elog "following commands:"
+       elog
+       elog "  mkdir -p ~/.mcabber"
+       elog "  bzcat ${EROOT}usr/share/doc/${PF}/mcabberrc.example.bz2 >~/.mcabber/mcabberrc"
+       elog
+       elog "Then edit ~/.mcabber/mcabberrc with your favorite editor."
+       elog
+       elog "See the CONFIGURATION FILE and FILES sections of the mcabber"
+       elog "manual page (section 1) for more information."
+       elog
+       elog "From version 0.9.0 on, MCabber supports PGP encryption of messages."
+       elog "See README_PGP.txt for details."
+       echo
+       einfo "Check out ${EROOT}usr/share/${PN} for contributed themes and event scripts."
+       echo
+}