net-irc/konversation: Port away from deprecated KWindowSystem API
authorAndreas Sturmlechner <asturm@gentoo.org>
Fri, 17 Apr 2020 19:42:14 +0000 (21:42 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 17 Apr 2020 20:58:46 +0000 (22:58 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
net-irc/konversation/files/konversation-1.7.5-kf5windowsystem-5.63.patch [new file with mode: 0644]
net-irc/konversation/konversation-1.7.5-r2.ebuild

diff --git a/net-irc/konversation/files/konversation-1.7.5-kf5windowsystem-5.63.patch b/net-irc/konversation/files/konversation-1.7.5-kf5windowsystem-5.63.patch
new file mode 100644 (file)
index 0000000..cf93b3b
--- /dev/null
@@ -0,0 +1,37 @@
+From 4295aba5c02533040723d140e062aebd231b3f18 Mon Sep 17 00:00:00 2001
+From: David Faure <faure@kde.org>
+Date: Thu, 28 Nov 2019 12:56:34 +0100
+Subject: Port away from deprecated KWindowSystem API (with ifdefs)
+
+---
+ src/application.cpp | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/src/application.cpp b/src/application.cpp
+index 4667c24..538624b 100644
+--- a/src/application.cpp
++++ b/src/application.cpp
+@@ -50,6 +50,7 @@
+ #include <KTextEdit>
+ #include <KSharedConfig>
+ #include <KStartupInfo>
++#include <kwindowsystem_version.h>
+ using namespace Konversation;
+@@ -1392,7 +1393,12 @@ void Application::handleActivate(const QStringList& arguments)
+     newInstance(m_commandLineParser);
++#if KWINDOWSYSTEM_VERSION <= QT_VERSION_CHECK(5, 62, 0)
+     KStartupInfo::setNewStartupId(mainWindow, KStartupInfo::startupId());
++#else
++    mainWindow->setAttribute(Qt::WA_NativeWindow, true);
++    KStartupInfo::setNewStartupId(mainWindow->windowHandle(), KStartupInfo::startupId());
++#endif
+     mainWindow->show();
+     mainWindow->raise();
+ }
+-- 
+cgit v1.1
+
index f43ed032dde1c391c4905b12d4c996cce9b0ae78..9940dae72376fd469bf79adb47059ac47c7b87ca 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 
 ECM_HANDBOOK="forceoptional"
-KFMIN=5.60.0
+KFMIN=5.63.0
 QTMIN=5.12.3
 inherit ecm kde.org
 
@@ -62,6 +62,7 @@ PATCHES=(
        "${FILESDIR}"/${P}-fix-regex-for-cap-ack.patch
        "${FILESDIR}"/${P}-missing-header.patch
        "${FILESDIR}"/${P}-QElapsedTimer.patch
+       "${FILESDIR}"/${P}-kf5windowsystem-5.63.patch
 )
 
 src_configure() {