dev-python/invoke: RESTRICT test
authorVirgil Dupras <vdupras@gentoo.org>
Fri, 10 May 2019 17:59:58 +0000 (13:59 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Fri, 10 May 2019 18:05:59 +0000 (14:05 -0400)
Depends on pytest-relaxed which is about to be last-rited.

Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

dev-python/invoke/invoke-1.1.1.ebuild

index 8317fccae1899bc131c910f74c7ac353bd9c5207..3f4449f2ebcf512c20b0637dde54b7658cf3db05 100644 (file)
@@ -12,23 +12,10 @@ SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
 LICENSE="BSD-2"
 SLOT="0"
 KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="test"
+IUSE=""
 
-BDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/mock
-               >=dev-python/pytest-3.0
-               >=dev-python/pytest-relaxed-1.1.4
-       )"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
 RDEPEND=""
 
-PATCHES=(
-       "${FILESDIR}/${PN}-1.1.0-skip-pty-tests.patch"
-)
-
-python_test() {
-       # -s flag is important: tests fail when pytest isn't in "no capture" mode
-       # -p pytest_relaxed: this plugin has to be loaded explicitly
-       pytest -s -v -p pytest_relaxed.plugin || die "Tests failed"
-}
+# Depends on broken pytest-relaxed plugin
+RESTRICT="test"