games-arcade/performous: Fix building with media-libs/jpeg
authorDavid Seifert <soap@gentoo.org>
Thu, 11 Apr 2019 18:57:39 +0000 (20:57 +0200)
committerDavid Seifert <soap@gentoo.org>
Thu, 11 Apr 2019 18:58:19 +0000 (20:58 +0200)
Closes: https://bugs.gentoo.org/649280
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: David Seifert <soap@gentoo.org>
games-arcade/performous/files/performous-1.1-jpeg-9c.patch [new file with mode: 0644]
games-arcade/performous/performous-1.1-r1.ebuild

diff --git a/games-arcade/performous/files/performous-1.1-jpeg-9c.patch b/games-arcade/performous/files/performous-1.1-jpeg-9c.patch
new file mode 100644 (file)
index 0000000..d878cec
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/common/image.cc
++++ b/common/image.cc
+@@ -180,7 +180,7 @@
+       }
+       jpeg_create_decompress(&cinfo);
+       jpeg_mem_src(&cinfo, data.data(), data.size());
+-      if (jpeg_read_header(&cinfo, true) != JPEG_HEADER_OK) throw std::runtime_error("Cannot read header of " + filename.string());
++      if (jpeg_read_header(&cinfo, TRUE) != JPEG_HEADER_OK) throw std::runtime_error("Cannot read header of " + filename.string());
+       jpeg_start_decompress(&cinfo);
+       bitmap.resize(cinfo.output_width, cinfo.output_height);
+       unsigned stride = (bitmap.width * 3 + 3) & ~3;  // Number of bytes per row (word-aligned)
index 774e839768c3f2d745f958519501a06f24d3041b..ed88a66edefed2b58785bdb9c85309ae7745332f 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -63,6 +63,7 @@ PATCHES=(
        "${FILESDIR}"/${P}-gentoo.patch
        "${FILESDIR}"/${P}-linguas.patch
        "${FILESDIR}"/${P}-nomancompress.patch
+       "${FILESDIR}"/${P}-jpeg-9c.patch
 )
 
 src_prepare() {