sys-apps/util-linux: support libaudit usage
authorRobin H. Johnson <robbat2@gentoo.org>
Fri, 3 Apr 2020 22:53:39 +0000 (15:53 -0700)
committerRobin H. Johnson <robbat2@gentoo.org>
Fri, 3 Apr 2020 23:10:02 +0000 (16:10 -0700)
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
sys-apps/util-linux/metadata.xml
sys-apps/util-linux/util-linux-2.35.1-r1.ebuild

index d707189c1c8d87c08c02fca9d7619ede24dd8a30..121dd51cf546bad2b45820539631739860f8aa72 100644 (file)
@@ -6,6 +6,7 @@
        <name>Gentoo Base System</name>
 </maintainer>
 <use>
+       <flag name="audit">Use <pkg>sys-process/audit</pkg> to emit audit messages about system changes</flag>
        <flag name="caps">build setpriv helper (run programs with diff capabilities)</flag>
        <flag name="cramfs">build mkfs/fsck helpers for cramfs filesystems</flag>
        <flag name="cryptsetup">Use <pkg>sys-fs/cryptsetup</pkg> to have built-in dm-verity in libmount</flag>
index 9abd2b066aab140290652967af19a5b5f806bba7..aeb4cff8ef2f498725560c650a79037e7d591e3f 100644 (file)
@@ -25,12 +25,13 @@ HOMEPAGE="https://www.kernel.org/pub/linux/utils/util-linux/ https://github.com/
 
 LICENSE="GPL-2 GPL-3 LGPL-2.1 BSD-4 MIT public-domain"
 SLOT="0"
-IUSE="build caps +cramfs cryptsetup fdformat hardlink kill +logger ncurses nls pam python +readline selinux slang static-libs su +suid systemd test tty-helpers udev unicode userland_GNU"
+IUSE="audit build caps +cramfs cryptsetup fdformat hardlink kill +logger ncurses nls pam python +readline selinux slang static-libs su +suid systemd test tty-helpers udev unicode userland_GNU"
 
 # Most lib deps here are related to programs rather than our libs,
 # so we rarely need to specify ${MULTILIB_USEDEP}.
 RDEPEND="
        virtual/libcrypt:=
+       audit? ( >=sys-process/audit-2.6:= )
        caps? ( sys-libs/libcap-ng )
        cramfs? ( sys-libs/zlib:= )
        cryptsetup? ( sys-fs/cryptsetup )
@@ -171,6 +172,7 @@ multilib_src_configure() {
                $(multilib_native_use_with udev)
                $(multilib_native_usex ncurses "$(use_with unicode ncursesw)" '--without-ncursesw')
                $(multilib_native_usex ncurses "$(use_with !unicode ncurses)" '--without-ncurses')
+               $(multilib_native_use_with audit)
                $(tc-has-tls || echo --disable-tls)
                $(use_enable nls)
                $(use_enable unicode widechar)