dev-libs/grantlee: Fix build with Qt 5.13
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 17 Feb 2019 13:04:15 +0000 (14:04 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 17 Feb 2019 13:04:36 +0000 (14:04 +0100)
Package-Manager: Portage-2.3.60, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-libs/grantlee/files/grantlee-5.1.0-qt-5.13.patch [new file with mode: 0644]
dev-libs/grantlee/grantlee-5.1.0.ebuild

diff --git a/dev-libs/grantlee/files/grantlee-5.1.0-qt-5.13.patch b/dev-libs/grantlee/files/grantlee-5.1.0-qt-5.13.patch
new file mode 100644 (file)
index 0000000..67a92c1
--- /dev/null
@@ -0,0 +1,27 @@
+From 0cee029ee03ab4906c6d19b57458b5036852b0f8 Mon Sep 17 00:00:00 2001
+From: Michael Pyne <mpyne@kde.org>
+Date: Tue, 18 Dec 2018 17:47:21 -0500
+Subject: [PATCH] Fix build with Qt 5.13 / GCC 8.2.
+
+At this point Grantlee doesn't build for me because QList is an
+incomplete type. I think the compiler is right to complain, so I fix by
+including the appropriate header.
+
+Fixes issue #47.
+---
+ templates/lib/lexer_p.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/templates/lib/lexer_p.h b/templates/lib/lexer_p.h
+index 275aeea..1ae451a 100644
+--- a/templates/lib/lexer_p.h
++++ b/templates/lib/lexer_p.h
+@@ -24,7 +24,7 @@
+ #include "textprocessingmachine_p.h"
+ #include "token.h"
+-template <typename T> class QList;
++#include <QList>
+ namespace Grantlee
+ {
index 21f665921e53110405b813eabb4640da541c57f9..328ce49c302e49986f390f08b901a95031babd23 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -29,7 +29,8 @@ DOCS=( AUTHORS CHANGELOG README.md )
 
 PATCHES=(
        "${FILESDIR}/${PN}-0.3.0-nonfatal-warnings.patch"
-       "${FILESDIR}/${PN}-5.1.0-slot.patch"
+       "${FILESDIR}/${P}-slot.patch"
+       "${FILESDIR}/${P}-qt-5.13.patch"
 )
 
 src_prepare() {