app-text/unac: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Sun, 12 Jan 2020 17:06:38 +0000 (18:06 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 12 Jan 2020 17:06:38 +0000 (18:06 +0100)
Closes: https://bugs.gentoo.org/704976
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
app-text/unac/files/unac-1.8.0-debian-gcc-4.4-bug-556379.patch
app-text/unac/unac-1.8.0.ebuild

index ca1d50274da6edee3b71c3de1d7d18f61823d8db..a006c4fbd787db6cce3df1ac8d53867e7395a21f 100644 (file)
@@ -1,8 +1,7 @@
 See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=556379
 
-diff -r fd7eb0d70970 unac-1.8.0/unac.c
---- a/unac-1.8.0/unac.c        Fri Sep 17 10:35:14 2010 +0200
-+++ b/unac-1.8.0/unac.c        Fri Sep 17 10:36:07 2010 +0200
+--- a/unac.c
++++ b/unac.c
 @@ -13873,9 +13873,9 @@
      *out_lengthp = 0;
    } else {
@@ -15,9 +14,8 @@ diff -r fd7eb0d70970 unac-1.8.0/unac.c
    
      if(convert(charset, utf16be(), in, in_length, &utf16, &utf16_length) < 0) {
        return -1;
-diff -r fd7eb0d70970 unac-1.8.0/unaccent.c
---- a/unac-1.8.0/unaccent.c    Fri Sep 17 10:35:14 2010 +0200
-+++ b/unac-1.8.0/unaccent.c    Fri Sep 17 10:40:34 2010 +0200
+--- a/unaccent.c
++++ b/unaccent.c
 @@ -90,7 +90,7 @@
      const char* charset = argv[optind++];
  
index 72fcf4f08e3f6052b2dabbfc29267f7ea9fef13b..fed5a147afe52cd3606f2c99c4cf2e0bfbcd3cd3 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="5"
+EAPI=7
 
-inherit autotools eutils
+inherit autotools
 
 DESCRIPTION="Library and command-line tool for removing accents from characters"
 HOMEPAGE="http://www.nongnu.org/unac/"
@@ -12,7 +12,7 @@ SRC_URI="mirror://debian/pool/main/u/unac/${P/-/_}.orig.tar.gz"
 LICENSE="GPL-2+"
 SLOT="0"
 KEYWORDS="amd64 x86"
-IUSE="static-libs test"
+IUSE="test"
 RESTRICT="!test? ( test )"
 
 RDEPEND="virtual/libiconv"
@@ -21,29 +21,26 @@ DEPEND="${RDEPEND}
 
 S="${WORKDIR}/${P}.orig"
 
+PATCHES=(
+       "${FILESDIR}"/${P}-debian-gcc-4.4-bug-556379.patch
+       "${FILESDIR}"/${P}-automake-1.13.1.patch
+)
+
 src_prepare() {
-       epatch "${FILESDIR}/${P}-debian-gcc-4.4-bug-556379.patch"
-       epatch "${FILESDIR}/${P}-automake-1.13.1.patch"
+       default
+       rm README.Debian || die
        # otherwise automake will fail
        touch config.rpath
        eautoreconf
 }
 
 src_configure() {
-       econf $(use_enable static-libs static)
+       econf --disable-static
 }
 
 src_install() {
-       DOCS="AUTHORS ChangeLog NEWS README THANKS"
        default
-       prune_libtool_files
-}
 
-pkg_postinst() {
-       einfo "Examples of using unaccent from the command line:"
-       einfo "unaccent utf8 été"
-       einfo "echo -e '\\\\0303\\\\0251t\\\\0303\\\\0251' | unaccent utf8"
-       einfo "unaccent ISO-8859-1 < myfile > myfile.unaccent"
-       einfo
-       einfo "See man unaccent and man unac for more information."
+       # no static archives
+       find "${D}" -name '*.la' -delete || die
 }