sci-misc/boinc: Rename desktop file to boincmgr.desktop
authorSven Eden <yamakuzure@gmx.net>
Thu, 8 Dec 2016 09:24:53 +0000 (10:24 +0100)
committerDavid Seifert <soap@gentoo.org>
Wed, 4 Jan 2017 13:42:02 +0000 (15:42 +0200)
Gentoo-Bug: 599910

This is a workaround to the following issue:
The desktop entry filename and the executable filename are different.
Binary:       boincmgr
Desktop file: boincmgr-boinc.desktop
This causes GNOME to use an ugly icon in the launcher. It is also not
possible to add the BOINC icon to the favorites.
Renaming the desktop file to boincmgr.desktop fixes both issues,
although this is only a hotfix. The GNOME shell should be perfectly
capable of using any well formed desktop file regardless of its name.

Package-Manager: portage-2.3.3
Closes: https://github.com/gentoo/gentoo/pull/3056

sci-misc/boinc/boinc-7.2.44-r2.ebuild [moved from sci-misc/boinc/boinc-7.2.44-r1.ebuild with 96% similarity]
sci-misc/boinc/boinc-7.4.52-r2.ebuild [moved from sci-misc/boinc/boinc-7.4.52-r1.ebuild with 96% similarity]
sci-misc/boinc/boinc-7.6.33-r2.ebuild [moved from sci-misc/boinc/boinc-7.6.33-r1.ebuild with 96% similarity]

similarity index 96%
rename from sci-misc/boinc/boinc-7.2.44-r1.ebuild
rename to sci-misc/boinc/boinc-7.2.44-r2.ebuild
index bc0952dde73f4293131e1bd95554873adf8362b4..130e512e420da0d9ec122b7f58b662ba07b062b3 100644 (file)
@@ -118,6 +118,10 @@ src_install() {
                        newicon -s $s "${WORKDIR}"/boinc_${s}.png boinc.png
                done
                make_desktop_entry boincmgr "${PN}" "${PN}" "Math;Science" "Path=/var/lib/${PN}"
+
+               # Rename the desktop file to boincmgr.desktop to (hot)fix bug 599910
+               mv "${ED%/}"/usr/share/applications/boincmgr{-${PN},}.desktop || \
+                       die "Failed to rename desktop file"
        fi
 
        # cleanup cruft
similarity index 96%
rename from sci-misc/boinc/boinc-7.4.52-r1.ebuild
rename to sci-misc/boinc/boinc-7.4.52-r2.ebuild
index 0a508d3c2dea3be7a93dcc1585bf43435e4c5277..cf02d0eb2a03b1227c5795f0c0dfef96fd8f2e53 100644 (file)
@@ -123,6 +123,10 @@ src_install() {
                        newicon -s $s "${WORKDIR}"/boinc_${s}.png boinc.png
                done
                make_desktop_entry boincmgr "${PN}" "${PN}" "Math;Science" "Path=/var/lib/${PN}"
+
+               # Rename the desktop file to boincmgr.desktop to (hot)fix bug 599910
+               mv "${ED%/}"/usr/share/applications/boincmgr{-${PN},}.desktop || \
+                       die "Failed to rename desktop file"
        fi
 
        # cleanup cruft
similarity index 96%
rename from sci-misc/boinc/boinc-7.6.33-r1.ebuild
rename to sci-misc/boinc/boinc-7.6.33-r2.ebuild
index 0a508d3c2dea3be7a93dcc1585bf43435e4c5277..cf02d0eb2a03b1227c5795f0c0dfef96fd8f2e53 100644 (file)
@@ -123,6 +123,10 @@ src_install() {
                        newicon -s $s "${WORKDIR}"/boinc_${s}.png boinc.png
                done
                make_desktop_entry boincmgr "${PN}" "${PN}" "Math;Science" "Path=/var/lib/${PN}"
+
+               # Rename the desktop file to boincmgr.desktop to (hot)fix bug 599910
+               mv "${ED%/}"/usr/share/applications/boincmgr{-${PN},}.desktop || \
+                       die "Failed to rename desktop file"
        fi
 
        # cleanup cruft