net-misc/youtube-dl: Version 2018.03.14.
authorJeroen Roovers <jer@gentoo.org>
Fri, 16 Mar 2018 15:56:03 +0000 (16:56 +0100)
committerJeroen Roovers <jer@gentoo.org>
Fri, 16 Mar 2018 15:58:11 +0000 (16:58 +0100)
Package-Manager: Portage-2.3.24, Repoman-2.3.6

net-misc/youtube-dl/Manifest
net-misc/youtube-dl/youtube-dl-2018.03.14.ebuild [new file with mode: 0644]

index fffccd6b1bb8c95997b67b2ec7344973236f7693..8addba847f06370f6b9b6d4c044fc1329a86bcee 100644 (file)
@@ -2,3 +2,4 @@ DIST youtube-dl-2017.03.16.tar.gz 2631620 BLAKE2B 2aff8710a296140a4329b0f8e7f575
 DIST youtube-dl-2017.11.15.tar.gz 2834012 BLAKE2B fd93e3923f99874be58681a886c09e31ac10063975ab636badf27e59b44743c72cddf05e3a431c49ffd0f7b40f9b005f4d90feff85d4ca889dee80833300b076 SHA512 e10c0d53db7fdfb02610b53f54046c0a9354b305ba05c5d00a43649a283a6449263f66ff56171d52cf18f906c6aeccc25dc48ea708b4b1bb2b8323b937abca96
 DIST youtube-dl-2018.02.26.tar.gz 2910402 BLAKE2B 4cf4cf0971962ca5aa688f91ca56eda6bd582e0244f233264dc0ce8b7ee26e3cbad59c60b2c3e11e024c1a2816ddb87d1c2228f8111c8ee0ea1459bf301b5068 SHA512 ca89b8c68a321855a37a56a1126f105b5d18a39bf24ad1ce662a157f4e9074658fa3c2b11f1cf3f1d33d448e2e4cc509d9a9e9d3e71c35933bcf11af702dfc5b
 DIST youtube-dl-2018.03.03.tar.gz 2914319 BLAKE2B 793a26dfad0149e74aacdc861c38ec953728915ac1890dbfa3a52da36bbc26c8155fb5dbb5db9c8857e6a3fb6798b2caf6491bc9b3a18374ceab9924b4cbffc4 SHA512 fe7a3d16b7773f8ff4cc7815fe40aee83020fed68b8218743694432d4e298b7d811b0e52a4f9ab0e20a5eef57399c73dd42a7b1ee3fc950f69c32a102d329a4f
+DIST youtube-dl-2018.03.14.tar.gz 2930477 BLAKE2B b0acd81acbaebf698a665f7d744cefb0c07e1e07d3430ee816ca5bbb19ebaa2d908cebf0e639369af8f8431cc9c72706c5a343f5907778283bc5a365caae8e39 SHA512 9bbc382872f532c2fd66e6beabaa277c81bd920939df8e4511736c404bffdf9246b3cb6afd06e4259cb575ec46733107dca7579044bcdca9245064b14ec26a07
diff --git a/net-misc/youtube-dl/youtube-dl-2018.03.14.ebuild b/net-misc/youtube-dl/youtube-dl-2018.03.14.ebuild
new file mode 100644 (file)
index 0000000..db51a77
--- /dev/null
@@ -0,0 +1,115 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="+offensive test"
+
+RDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+       ${RDEPEND}
+       test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+       if ! use offensive; then
+               sed -i -e "/..version../s|'$|+gentoo.no.offensive.sites'|g" \
+                       youtube_dl/version.py || die
+               # these have single line import statements
+               local xxx=(
+                       alphaporno anysex behindkink camwithher chaturbate eporner
+                       eroprofile extremetube foxgay goshgay hellporno hentaistigma
+                       hornbunny keezmovies lovehomeporn mofosex myvidster porn91 porncom
+                       pornflip pornhd pornotube pornovoisines pornoxo ruleporn sexu
+                       slutload spankbang spankwire sunporno thisav tube8 vporn
+                       watchindianporn xbef xnxx xtube xvideos xxxymovies youjizz youporn
+               )
+               # these have multi-line import statements
+               local mxxx=(
+                       drtuber fourtube motherless pornhub redtube tnaflix xhamster
+               )
+               # do single line imports
+               sed -i \
+                       -e $( printf '/%s/d;' ${xxx[@]} ) \
+                       youtube_dl/extractor/extractors.py \
+                       || die
+
+               # do multiple line imports
+               sed -i \
+                       -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+                       youtube_dl/extractor/extractors.py \
+                       || die
+
+               sed -i \
+                       -e $( printf '/%s/d;' ${mxxx[@]} ) \
+                       youtube_dl/extractor/generic.py \
+                       || die
+
+               rm \
+                       $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+                       $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+                       test/test_age_restriction.py \
+                       || die
+       fi
+
+       eapply_user
+
+       distutils-r1_python_prepare_all
+}
+
+src_compile() {
+       distutils-r1_src_compile
+}
+
+python_test() {
+       emake test
+}
+
+python_install_all() {
+       dodoc README.txt
+       doman ${PN}.1
+
+       newbashcomp ${PN}.bash-completion ${PN}
+
+       insinto /usr/share/zsh/site-functions
+       newins youtube-dl.zsh _youtube-dl
+
+       insinto /usr/share/fish/completions
+       doins youtube-dl.fish
+
+       distutils-r1_python_install_all
+
+       rm -r "${ED}"/usr/etc || die
+       rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+       elog "youtube-dl(1) / https://bugs.gentoo.org/355661 /"
+       elog "https://github.com/rg3/youtube-dl/blob/master/README.md#faq :"
+       elog
+       elog "${PN} works fine on its own on most sites. However, if you want"
+       elog "to convert video/audio, you'll need avconf (media-video/libav) or"
+       elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
+       elog "videos can be retrieved in a higher quality format without sound."
+       elog "${PN} will detect whether avconv/ffmpeg is present and"
+       elog "automatically pick the best option."
+
+       elog
+       elog "Videos or video formats streamed via RTMP protocol can only be"
+       elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+       elog "Downloading MMS and RTSP videos requires either mplayer"
+       elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
+}