dev-perl/Authen-NTLM: -r bump for EAPI7
authorKent Fredric <kentnl@gentoo.org>
Wed, 29 Apr 2020 23:05:15 +0000 (11:05 +1200)
committerKent Fredric <kentnl@gentoo.org>
Wed, 29 Apr 2020 23:14:40 +0000 (11:14 +1200)
- EAPI7
- Parallel Tests
- Remove redundant OPTIMIZE (no XS here)

Package-Manager: Portage-2.3.97, Repoman-2.3.22
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/Authen-NTLM/Authen-NTLM-1.90.0-r2.ebuild [new file with mode: 0644]

diff --git a/dev-perl/Authen-NTLM/Authen-NTLM-1.90.0-r2.ebuild b/dev-perl/Authen-NTLM/Authen-NTLM-1.90.0-r2.ebuild
new file mode 100644 (file)
index 0000000..01a26e9
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_NAME=NTLM
+DIST_AUTHOR=NBEBOUT
+DIST_VERSION=1.09
+inherit perl-module
+
+DESCRIPTION="An NTLM authentication module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=virtual/perl-MIME-Base64-3.00
+       dev-perl/Digest-HMAC"
+BDEPEND="${RDEPEND}
+       test? ( virtual/perl-Test-Simple )
+"
+PERL_RM_FILES=(
+       "t/99_pod.t"
+)