dev-python/spyder: allow newer parso versions
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>
Sat, 28 Mar 2020 13:48:33 +0000 (14:48 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Sat, 28 Mar 2020 14:21:18 +0000 (16:21 +0200)
Closes: https://bugs.gentoo.org/715148
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Closes: https://github.com/gentoo/gentoo/pull/15149
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-python/spyder/files/spyder-4.1.1-allow-newer-parso.patch [new file with mode: 0644]
dev-python/spyder/spyder-4.1.1.ebuild

diff --git a/dev-python/spyder/files/spyder-4.1.1-allow-newer-parso.patch b/dev-python/spyder/files/spyder-4.1.1-allow-newer-parso.patch
new file mode 100644 (file)
index 0000000..4b1c8d7
--- /dev/null
@@ -0,0 +1,39 @@
+diff --git a/requirements/conda.txt b/requirements/conda.txt
+index 2e5e4e1..e5f427e 100644
+--- a/requirements/conda.txt
++++ b/requirements/conda.txt
+@@ -14,7 +14,7 @@ keyring
+ nbconvert >=4.0
+ numpydoc >=0.6.0
+ Paramiko >=2.4.0
+-parso =0.5.2
++parso >=0.5.2
+ pexpect >=4.4.0
+ pickleshare >=0.4
+ psutil >=5.3
+diff --git a/setup.py b/setup.py
+index 2d5d58b..f008824 100644
+--- a/setup.py
++++ b/setup.py
+@@ -218,7 +218,7 @@ install_requires = [
+     'numpydoc>=0.6.0',
+     # Required to get SSH connections to remote kernels
+     'paramiko>=2.4.0;platform_system=="Windows"',
+-    'parso==0.5.2',
++    'parso>=0.5.2',
+     'pexpect>=4.4.0',
+     'pickleshare>=0.4',
+     'psutil>=5.3',
+diff --git a/spyder/dependencies.py b/spyder/dependencies.py
+index 7c88ab6..60950a8 100644
+--- a/spyder/dependencies.py
++++ b/spyder/dependencies.py
+@@ -41,7 +41,7 @@ KEYRING_REQVER = None
+ NBCONVERT_REQVER = '>=4.0'
+ NUMPYDOC_REQVER = '>=0.6.0'
+ PARAMIKO_REQVER = '>=2.4.0'
+-PARSO_REQVER = '=0.5.2'
++PARSO_REQVER = '>=0.5.2'
+ PEXPECT_REQVER = '>=4.4.0'
+ PICKLESHARE_REQVER = '>=0.4'
+ PSUTIL_REQVER = '>=5.3'
index 440d4fa18c2253df7b545a1f881dafceb8701063..0116d491f8c402b955123754147cd94cf9726eb0 100644 (file)
@@ -33,7 +33,7 @@ RDEPEND="
        dev-python/keyring[${PYTHON_USEDEP}]
        >=dev-python/nbconvert-4.0[${PYTHON_USEDEP}]
        >=dev-python/numpydoc-0.6.0[${PYTHON_USEDEP}]
-       ~dev-python/parso-0.5.2[${PYTHON_USEDEP}]
+       >=dev-python/parso-0.5.2[${PYTHON_USEDEP}]
        >=dev-python/pexpect-4.4.0[${PYTHON_USEDEP}]
        >=dev-python/pickleshare-0.4[${PYTHON_USEDEP}]
        >=dev-python/psutil-5.3[${PYTHON_USEDEP}]
@@ -69,8 +69,11 @@ DEPEND="test? (
 # Based on the courtesy of Arfrever
 # This patch removes a call to update-desktop-database during build
 # This fails because access is denied to this command during build
-PATCHES=( "${FILESDIR}/${P}-build.patch"
-       "${FILESDIR}/${P}-py3-only.patch" )
+PATCHES=(
+       "${FILESDIR}/${P}-build.patch"
+       "${FILESDIR}/${P}-py3-only.patch"
+       "${FILESDIR}/${P}-allow-newer-parso.patch"
+)
 
 distutils_enable_tests pytest
 distutils_enable_sphinx docs/doc --no-autodoc