dev-python/python-sense-hat: New package
authorConrad Kostecki <conrad@kostecki.com>
Sat, 7 Jul 2018 22:24:01 +0000 (00:24 +0200)
committerTony Vroon <chainsaw@gentoo.org>
Wed, 11 Jul 2018 08:21:50 +0000 (09:21 +0100)
Closes: https://bugs.gentoo.org/571234
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Closes: https://github.com/gentoo/gentoo/pull/9108
Closes: https://bugs.gentoo.org/571234

dev-python/python-sense-hat/Manifest [new file with mode: 0644]
dev-python/python-sense-hat/metadata.xml [new file with mode: 0644]
dev-python/python-sense-hat/python-sense-hat-2.2.0.ebuild [new file with mode: 0644]

diff --git a/dev-python/python-sense-hat/Manifest b/dev-python/python-sense-hat/Manifest
new file mode 100644 (file)
index 0000000..3a7e5d9
--- /dev/null
@@ -0,0 +1 @@
+DIST python-sense-hat-2.2.0.tar.gz 20841 BLAKE2B 59e6b9111fb90493e6bda00ce4a4c143dcb84d8b6529efadaf2f337adb38a8fb4287cbd9a303070ea4f335f1e03c6f4789e6f8fbe64a7c70db20675bdae7c6a1 SHA512 71914f6f22206cff23992a6908698978741a46bf9b98648388bac4550f39e8de73db6bd389b79585eba6e82160649a8c8da4217d515bbdbcb50d47218415f3ac
diff --git a/dev-python/python-sense-hat/metadata.xml b/dev-python/python-sense-hat/metadata.xml
new file mode 100644 (file)
index 0000000..54d5423
--- /dev/null
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>ck+gentoo@bl4ckb0x.de</email>
+               <name>Conrad Kostecki</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/dev-python/python-sense-hat/python-sense-hat-2.2.0.ebuild b/dev-python/python-sense-hat/python-sense-hat-2.2.0.ebuild
new file mode 100644 (file)
index 0000000..e941ad6
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Raspberry Pi Sense HAT python library"
+HOMEPAGE="https://github.com/RPi-Distro/python-sense-hat"
+SRC_URI="https://github.com/RPi-Distro/python-sense-hat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~arm ~arm64"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+       dev-python/pillow[${PYTHON_USEDEP}]
+       dev-python/rtimulib[${PYTHON_USEDEP}]"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       ${RDEPEND}"