Add new ebuild for openxcom game, only live ebuild as releases do not use autotools...
authorTomas Chvatal <scarabeus@gentoo.org>
Wed, 19 Oct 2011 13:27:24 +0000 (13:27 +0000)
committerTomas Chvatal <scarabeus@gentoo.org>
Wed, 19 Oct 2011 13:27:24 +0000 (13:27 +0000)
Package-Manager: portage-2.2.0_alpha68/cvs/Linux x86_64

games-strategy/openxcom/ChangeLog [new file with mode: 0644]
games-strategy/openxcom/metadata.xml [new file with mode: 0644]
games-strategy/openxcom/openxcom-9999.ebuild [new file with mode: 0644]

diff --git a/games-strategy/openxcom/ChangeLog b/games-strategy/openxcom/ChangeLog
new file mode 100644 (file)
index 0000000..168d6cf
--- /dev/null
@@ -0,0 +1,11 @@
+# ChangeLog for games-strategy/openxcom
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/openxcom/ChangeLog,v 1.1 2011/10/19 13:27:24 scarabeus Exp $
+
+*openxcom-9999 (19 Oct 2011)
+
+  19 Oct 2011; Tomáš Chvátal <scarabeus@gentoo.org> +openxcom-9999.ebuild,
+  +metadata.xml:
+  Add new ebuild for openxcom game, only live ebuild as releases do not use
+  autotools yet.
+
diff --git a/games-strategy/openxcom/metadata.xml b/games-strategy/openxcom/metadata.xml
new file mode 100644 (file)
index 0000000..b11afe2
--- /dev/null
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+       <email>scarabeus@gentoo.org</email>
+       <name>Tomáš Chvátal</name>
+</maintainer>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-strategy/openxcom/openxcom-9999.ebuild b/games-strategy/openxcom/openxcom-9999.ebuild
new file mode 100644 (file)
index 0000000..6856012
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/openxcom/openxcom-9999.ebuild,v 1.1 2011/10/19 13:27:24 scarabeus Exp $
+
+EAPI=3
+
+EGIT_REPO_URI="https://github.com/SupSuper/OpenXcom.git"
+[[ ${PV} = 9999 ]] && SCM_ECLASS="git-2 autotools"
+inherit games ${SCM_ECLASS}
+unset SCM_ECLASS
+
+DESCRIPTION="Open-source reimplementation of the original X-Com"
+HOMEPAGE="http://openxcom.org/"
+[[ ${PV} = 9999 ]] || SRC_URI=""
+
+LICENSE="GPL-3"
+SLOT="0"
+[[ ${PV} = 9999 ]] || KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="
+       dev-cpp/yaml-cpp
+       media-libs/libsdl
+       media-libs/sdl-gfx
+       media-libs/sdl-mixer
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+       [[ ${PV} = 9999 ]] && eautoreconf
+}
+
+src_configure() {
+       egamesconf
+}
+
+src_install() {
+       emake DESTDIR="${ED}" install || die
+
+       elog "Remember to put X-Com data to proper location:"
+       elog "    ${ED}/usr/share/${PN}/"
+       prepgamesdirs
+}