dev-python/flask-peewee: Replace distutils-r1 EXAMPLES use
authorDavid Seifert <soap@gentoo.org>
Fri, 20 Mar 2020 09:56:16 +0000 (10:56 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 20 Mar 2020 09:56:16 +0000 (10:56 +0100)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/flask-peewee/flask-peewee-0.6.7.ebuild

index cddfc580b3ff2835f55cd16ec4aff279fab8336c..b462257730d996d8fbf725e7fceb256787823f78 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -41,7 +41,11 @@ python_test() {
 
 python_install_all() {
        use doc && local HTML_DOCS=( docs/_build/html/. )
-       use examples && local EXAMPLES=( example/. )
+       if use examples; then
+               docinto examples
+               dodoc -r example/.
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
 
        distutils-r1_python_install_all
 }