Version bump for 7.2. Build/dist fix, and enable type1 support by default.
authorJoshua Baergen <joshuabaergen@gentoo.org>
Sat, 16 Dec 2006 16:48:24 +0000 (16:48 +0000)
committerJoshua Baergen <joshuabaergen@gentoo.org>
Sat, 16 Dec 2006 16:48:24 +0000 (16:48 +0000)
Closes #157710.
Package-Manager: portage-2.1.2_rc3-r5

x11-libs/libXfont/ChangeLog
x11-libs/libXfont/files/digest-libXfont-1.2.6 [new file with mode: 0644]
x11-libs/libXfont/libXfont-1.2.6.ebuild [new file with mode: 0644]

index 846d9824466736869e5de607191947cf777027ff..9e66420b969cd1f4678ec495d5a3e5aeb440a3aa 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for x11-libs/libXfont
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXfont/ChangeLog,v 1.53 2006/12/02 16:20:53 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXfont/ChangeLog,v 1.54 2006/12/16 16:48:24 joshuabaergen Exp $
+
+*libXfont-1.2.6 (16 Dec 2006)
+
+  16 Dec 2006; Joshua Baergen <joshuabaergen@gentoo.org>
+  -libXfont-1.2.5.ebuild, +libXfont-1.2.6.ebuild:
+  Version bump for 7.2.  Build/dist fix, and enable type1 support by default.
+  Closes #157710.
 
 *libXfont-1.2.5 (02 Dec 2006)
 
diff --git a/x11-libs/libXfont/files/digest-libXfont-1.2.6 b/x11-libs/libXfont/files/digest-libXfont-1.2.6
new file mode 100644 (file)
index 0000000..3a6604e
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 9f2c956b9a01f20a247a155d75270737 libXfont-1.2.6.tar.bz2 582191
+RMD160 2bf77e7c9bdb5aa0aa67e3ee2d05f3cf79722646 libXfont-1.2.6.tar.bz2 582191
+SHA256 9337670709697046e5071d028fb0c72e0e8b01b6890e952b8bd1021d7cd4fe9a libXfont-1.2.6.tar.bz2 582191
diff --git a/x11-libs/libXfont/libXfont-1.2.6.ebuild b/x11-libs/libXfont/libXfont-1.2.6.ebuild
new file mode 100644 (file)
index 0000000..b30352b
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXfont/libXfont-1.2.6.ebuild,v 1.1 2006/12/16 16:48:24 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+# SNAPSHOT="yes"
+
+inherit x-modular flag-o-matic
+
+DESCRIPTION="X.Org Xfont library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6"
+
+RDEPEND="x11-libs/xtrans
+       x11-libs/libfontenc
+       x11-proto/xproto
+       x11-proto/fontsproto
+       >=media-libs/freetype-2"
+DEPEND="${RDEPEND}
+       x11-proto/fontcacheproto"
+
+CONFIGURE_OPTIONS="$(use_enable ipv6)
+       --with-encodingsdir=/usr/share/fonts/encodings"
+
+pkg_setup() {
+       # No such function yet
+       # x-modular_pkg_setup
+
+       # (#125465) Broken with Bdirect support
+       filter-flags -Wl,-Bdirect
+       filter-ldflags -Bdirect
+       filter-ldflags -Wl,-Bdirect
+}