old
authorMike Frysinger <vapier@gentoo.org>
Sat, 16 Dec 2006 03:07:56 +0000 (03:07 +0000)
committerMike Frysinger <vapier@gentoo.org>
Sat, 16 Dec 2006 03:07:56 +0000 (03:07 +0000)
app-arch/gzip/files/digest-gzip-1.3.8 [deleted file]
app-arch/gzip/gzip-1.3.8.ebuild [deleted file]

diff --git a/app-arch/gzip/files/digest-gzip-1.3.8 b/app-arch/gzip/files/digest-gzip-1.3.8
deleted file mode 100644 (file)
index d1baaf5..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 116774b594a6d5e07fc9999f5f42ecb0 gzip-1.3.8.tar.gz 544865
-RMD160 42162c6f5a9a03e7a9ac81ad04bb32a15695861c gzip-1.3.8.tar.gz 544865
-SHA256 45bab5af629eafb45039a2a70792c4a30baee23926e36b0f5a0349806d43e089 gzip-1.3.8.tar.gz 544865
diff --git a/app-arch/gzip/gzip-1.3.8.ebuild b/app-arch/gzip/gzip-1.3.8.ebuild
deleted file mode 100644 (file)
index 15d6d7f..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/gzip-1.3.8.ebuild,v 1.1 2006/12/09 08:05:17 vapier Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Standard GNU compressor"
-HOMEPAGE="http://www.gnu.org/software/gzip/"
-SRC_URI="ftp://alpha.gnu.org/gnu/gzip/${P}.tar.gz
-       mirror://gentoo/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="nls static pic"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
-       nls? ( sys-devel/gettext )"
-PROVIDE="virtual/gzip"
-
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-       #epatch "${FILESDIR}"/${PN}-1.3.5-rsync.patch
-       epatch "${FILESDIR}"/${PN}-1.3.8-install-symlinks.patch
-}
-
-src_compile() {
-       use static && append-flags -static
-       # avoid text relocation in gzip
-       use pic && export DEFS="NO_ASM"
-       econf $(use_enable nls) || die
-       emake || die
-}
-
-src_install() {
-       emake install DESTDIR="${D}" || die
-       dodoc ChangeLog NEWS README THANKS TODO
-       docinto txt
-       dodoc algorithm.doc gzip.doc
-
-       # keep most things in /usr, just the fun stuff in /
-       dodir /bin
-       mv "${D}"/usr/bin/{gunzip,gzip,zcat} "${D}"/bin/ || die
-       dosym /bin/gunzip /usr/bin/gunzip || die
-}