dev-python/pipenv: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 11:49:18 +0000 (12:49 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 11:59:22 +0000 (12:59 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pipenv/Manifest
dev-python/pipenv/pipenv-9.0.0-r1.ebuild [deleted file]
dev-python/pipenv/pipenv-9.0.0-r2.ebuild [deleted file]
dev-python/pipenv/pipenv-9.0.0.ebuild [deleted file]

index 2cc1a0cd7ed246de970ce17d9e579cb326316078..28df266db99588a627d061ec702a92ec9793e473 100644 (file)
@@ -1,2 +1 @@
 DIST pipenv-2018.11.26.tar.gz 6560580 BLAKE2B a3846de696733b5f3f393163999d7f333b52accdcebadfd800507defd1108ac4ccb288b39fb805ecf03e417cfe0d1a8b2fc714a95e8ee4485f8622ff8fe4a1ca SHA512 59582ad4a0730083ea58867f7a5d9714290d62947f56bec80e154d4359fe1dff16e44974a7fba3841e5f2516f2ce9709baf9954c9fc40fd66ebc46c3060d4dea
-DIST pipenv-9.0.0.tar.gz 3859618 BLAKE2B 138e53b1ef08d036f4ded6b4ca9da1a88084ad3d987aea1c6783181de414f7b24a54d46b26c2171f0918a1b1c22e2dac983fafad8a80f4aa95f93979bebfe2df SHA512 ea2d5ada73288a5d20473d769e20d6d195f65c3d3aebe2e52a43e1641af916295a18810bdb74a611751e773bfdfbc0ea7190d61358dce66d4aa33fa4a6f6131f
diff --git a/dev-python/pipenv/pipenv-9.0.0-r1.ebuild b/dev-python/pipenv/pipenv-9.0.0-r1.ebuild
deleted file mode 100644 (file)
index 2982676..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python Development Workflow for Humans"
-HOMEPAGE="https://github.com/pypa/pipenv https://pypi.org/project/pipenv/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
-       >=dev-python/flake8-3.0.0[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       >=dev-python/pew-0.1.26[${PYTHON_USEDEP}]
-       >=dev-python/pip-9.0.1[${PYTHON_USEDEP}]
-       >dev-python/requests-2.18.0[${PYTHON_USEDEP}]
-       >=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       test? (
-               dev-python/pytest[${PYTHON_USEDEP}]
-       )"
-
-# not completely packed
-# requires networking
-RESTRICT="test"
-
-python_test() {
-       py.test -v -v || die
-}
diff --git a/dev-python/pipenv/pipenv-9.0.0-r2.ebuild b/dev-python/pipenv/pipenv-9.0.0-r2.ebuild
deleted file mode 100644 (file)
index 14b90d3..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python Development Workflow for Humans"
-HOMEPAGE="https://github.com/pypa/pipenv https://pypi.org/project/pipenv/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
-       >=dev-python/flake8-3.0.0[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       >=dev-python/pew-0.1.26[${PYTHON_USEDEP}]
-       >=dev-python/pip-9.0.1[${PYTHON_USEDEP}]
-       >dev-python/requests-2.18.0[${PYTHON_USEDEP}]
-       >=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]
-       "
-DEPEND="${RDEPEND}
-       test? (
-               dev-python/pytest[${PYTHON_USEDEP}]
-       )"
-
-# not completely packed
-# requires networking
-RESTRICT="test"
-
-python_test() {
-       py.test -v -v || die
-}
diff --git a/dev-python/pipenv/pipenv-9.0.0.ebuild b/dev-python/pipenv/pipenv-9.0.0.ebuild
deleted file mode 100644 (file)
index 32a7a8b..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python Development Workflow for Humans"
-HOMEPAGE="https://github.com/pypa/pipenv https://pypi.org/project/pipenv/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
-       dev-python/flake8
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       >=dev-python/pew-0.1.26[${PYTHON_USEDEP}]
-       >=dev-python/pip-9.0.1[${PYTHON_USEDEP}]
-       >dev-python/requests-2.18.0[${PYTHON_USEDEP}]
-       >=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]
-       test? (
-               dev-python/flake8[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-       )"
-
-# not completely packed
-# requires networking
-RESTRICT="test"
-
-python_test() {
-       py.test -v -v || die
-}