dev-perl/Validate-Net: Add build fix for Perl 5.26, bug 623146
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Sun, 2 Jul 2017 22:56:56 +0000 (00:56 +0200)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Sun, 2 Jul 2017 22:56:56 +0000 (00:56 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-perl/Validate-Net/Validate-Net-0.600.0-r1.ebuild

index d61d0b1101ec80b6b76e89cc512d8c39e63f009a..1b6e1a756029e2e9ebb81ed158e4bea1ad876484 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=6
 
-MODULE_AUTHOR=ADAMK
-MODULE_VERSION=0.6
+DIST_AUTHOR=ADAMK
+DIST_VERSION=0.6
 inherit perl-module
 
 DESCRIPTION="Format validation and more for Net:: related strings"
@@ -15,6 +15,11 @@ IUSE="test"
 
 RDEPEND="dev-perl/Class-Default"
 DEPEND="${RDEPEND}
-       test? ( virtual/perl-Test-Simple )"
+       test? ( virtual/perl-Test-Simple )
+"
 
-SRC_TEST="do"
+src_prepare() {
+       sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
+               die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+       perl-module_src_prepare
+}