media-gfx/graphviz: Inline myconf comments
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 14 Sep 2019 13:05:32 +0000 (15:05 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 14 Sep 2019 14:52:26 +0000 (16:52 +0200)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-gfx/graphviz/graphviz-2.42.1.ebuild

index 6a0e38d17e8ac6a479ecd38555b0110ad0254559..a26f2b5c6df4eecc446c0f71a0f9f46bf082193b 100644 (file)
@@ -187,14 +187,6 @@ src_prepare() {
 src_configure() {
        local myconf=(
                --enable-ltdl
-               --disable-silent-rules
-               $(use_enable static-libs static)
-       )
-
-       # libtool file collision, bug 276609
-       myconf+=( --without-included-ltdl --disable-ltdl-install )
-
-       myconf+=(
                $(use_with cairo pangocairo)
                $(use_with devil)
                $(use_enable gdk-pixbuf)
@@ -204,6 +196,7 @@ src_configure() {
                $(use_with lasi)
                $(use_with pdf poppler)
                $(use_with postscript ghostscript)
+               $(use_enable static-libs static)
                $(use_with svg rsvg)
                $(use_with X x)
                $(use_with X xaw)
@@ -215,35 +208,31 @@ src_configure() {
                --with-libgd
                --with-sfdp
                --without-ming
-       )
-
-       # new/experimental features, to be tested, disable for now
-       myconf+=(
+               # new/experimental features, to be tested, disable for now
                --with-cgraph
                --without-glitz
                --without-ipsepcola
                --without-smyrna
                --without-visio
-       )
-
-       # Bindings:
-       myconf+=(
+               # Bindings:
                $(use_enable guile)
-               --disable-io
                $(use_enable java)
+               $(use_enable perl)
+               $(use_enable python python2)
+               $(use_enable python python3)
+               $(use_enable ruby)
+               $(use_enable tcl)
+               --disable-io
                --disable-lua
                --disable-ocaml
-               $(use_enable perl)
                --disable-php
                --disable-python
-               $(use_enable python python2)
-               $(use_enable python python3)
                --disable-r
-               $(use_enable ruby)
                --disable-sharp
-               $(use_enable tcl)
+               # libtool file collision, bug #276609
+               --without-included-ltdl
+               --disable-ltdl-install
        )
-
        econf "${myconf[@]}"
 }