x11-libs/vte: bump to 0.58.3
authorMart Raudsepp <leio@gentoo.org>
Sat, 21 Mar 2020 13:21:45 +0000 (15:21 +0200)
committerMart Raudsepp <leio@gentoo.org>
Sat, 21 Mar 2020 16:22:04 +0000 (18:22 +0200)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
x11-libs/vte/Manifest
x11-libs/vte/vte-0.58.3.ebuild [new file with mode: 0644]

index 36ce84d3473ab0b09b8d828aac0027bc74b10dcc..8843f9fc24ad29aaeed3b62b2d9b069f54636497 100644 (file)
@@ -1,3 +1,5 @@
 DIST vte-0.28.2.tar.xz 962340 BLAKE2B 1e4b5977962265be77917ccfc9118ed93232c03d7a16b6c08a27e721fe71f8c1dd1783a439530d7b3d915111cb8cc78281f1e9e351d6a83edd31f224309ca1e9 SHA512 d6a50481aaa8946cca3779e0b328fef551be534d70366a75385d1f8ead3fcddec57bed85c7d4bc2d9f34546532129e63083aafa33cbb0efcbc7dc9d66e7c45f6
 DIST vte-0.54.1-command-notify.patch.xz 3428 BLAKE2B 75b0c22720276300be2e49e8444aa68fed77fb7a6cc6b0e93a5c2d41257626bd60ff1084d68579769cb3d85e7ec567927591746de48e860b138d0c1f24f64cc7 SHA512 a53da569f8168c8e9e21e186dcfc00bf9fdb78a0c767ba35033c1c1e4f836406b4d9bf70ee3e071f6c749fd6f72101a6960d201617bd0bc23021e1eeaac6fd0c
 DIST vte-0.56.4.tar.xz 1100952 BLAKE2B 3c3ec69f4078bdb07a4501df4aeb31aaeb7f9fa5a4631152d486fbb2c950362612cd9dff4abe25b93da6c712a37a20ccbf050ad33d96ec7b997bb1409189f60b SHA512 5a6c79b30f07c1f5848ef59028864d893cc605b9ad8f49ae819958aaed962d2ff96baad379f126381b8bf00015003c5a6dc28c792e4e050ba35090338bd7dabb
+DIST vte-0.58.3-command-notify.patch.xz 4964 BLAKE2B f8414d3bf124bd3de4c08e22a051feabdb11fbded7562a0bf9858fb8b8cf6327a3fdf7e18592eacd9f3608af5b720fe9a0cb598092a12c816d37d36899d88f6b SHA512 0de06ec0019127ec2729950228f8cae3e61a306207e177b8427789d4f6477f102d78232bd7f1a6e02cc218f507474427ad8366bc3c16c8a305b432dba96ba685
+DIST vte-0.58.3.tar.xz 514844 BLAKE2B 1f48e95ec81397937c8a5a3d34ea9a7d1835d6cacec6e1b90b78568505d509b375f55678462428dd01da00e7290e4543bbab2dbb0aea46a322788fbaf022427b SHA512 b0a38eb1cd7d923b0431af943dbdb89932833f9a2b0b8fc1fa9ee728c87418c1f5a424b2ccee661721093a80c569f3b41c721b0ba2302ba0c3a42d4c5e31aa9a
diff --git a/x11-libs/vte/vte-0.58.3.ebuild b/x11-libs/vte/vte-0.58.3.ebuild
new file mode 100644 (file)
index 0000000..d35818a
--- /dev/null
@@ -0,0 +1,76 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+VALA_USE_DEPEND="vapigen"
+VALA_MIN_API_VERSION="0.32"
+
+inherit gnome.org meson vala xdg
+
+DESCRIPTION="Library providing a virtual terminal emulator widget"
+HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/VTE"
+
+LICENSE="LGPL-3+ GPL-3+"
+SLOT="2.91"
+IUSE="+crypt debug gtk-doc +introspection +vala vanilla"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+REQUIRED_USE="vala? ( introspection )"
+
+SRC_URI="${SRC_URI} !vanilla? ( https://dev.gentoo.org/~leio/distfiles/${PN}-0.58.3-command-notify.patch.xz )"
+
+RDEPEND="
+       >=x11-libs/gtk+-3.16:3[introspection?]
+       >=dev-libs/fribidi-1.0.0
+       >=dev-libs/glib-2.40:2
+       crypt?  ( >=net-libs/gnutls-3.2.7:0= )
+       >=x11-libs/pango-1.22.0
+       >=dev-libs/libpcre2-10.21
+       sys-libs/zlib
+       introspection? ( >=dev-libs/gobject-introspection-1.56:= )
+       x11-libs/pango[introspection?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       dev-libs/libxml2:2
+       dev-util/glib-utils
+       gtk-doc? ( >=dev-util/gtk-doc-1.13
+               app-text/docbook-xml-dtd:4.1.2 )
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+
+       vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+       if ! use vanilla; then
+               # Part of https://src.fedoraproject.org/rpms/vte291/raw/f31/f/vte291-cntnr-precmd-preexec-scroll.patch
+               # Adds OSC 777 support for desktop notifications in gnome-terminal or elsewhere
+               eapply "${WORKDIR}"/${PN}-0.58.3-command-notify.patch
+       fi
+
+       # -Ddebugg option enables various debug support via VTE_DEBUG, but also ggdb3; strip the latter
+       sed -e '/ggdb3/d' -i meson.build || die
+
+       use vala && vala_src_prepare
+       xdg_src_prepare
+}
+
+src_configure() {
+       local emesonargs=(
+               $(meson_use debug debugg)
+               $(meson_use gtk-doc docs)
+               $(meson_use introspection gir)
+               -Dfribidi=true # pulled in by pango anyhow
+               $(meson_use crypt gnutls)
+               -Dgtk3=true
+               -Dgtk4=false
+               -Diconv=true
+               $(meson_use vala vapi)
+       )
+       meson_src_configure
+}
+
+src_install() {
+       meson_src_install
+       mv "${ED}"/etc/profile.d/vte{,-${SLOT}}.sh || die
+}