Bump to new release that uses gtk# 2, and do some cleanup.
authorPeter Johanson <latexer@gentoo.org>
Fri, 15 Dec 2006 03:56:36 +0000 (03:56 +0000)
committerPeter Johanson <latexer@gentoo.org>
Fri, 15 Dec 2006 03:56:36 +0000 (03:56 +0000)
Package-Manager: portage-2.1.2_pre2-r8

net-news/blam/ChangeLog
net-news/blam/blam-1.8.4_pre2.ebuild [new file with mode: 0644]
net-news/blam/files/blam-1.8.4_pre2-gtk-sharp-2.10-compat.diff [new file with mode: 0644]
net-news/blam/files/blam-1.8.4_pre2-remove-funky-non-printable.diff [new file with mode: 0644]
net-news/blam/files/digest-blam-1.8.4_pre2 [new file with mode: 0644]

index 445b0a032a5be3ef05c7765e57359b6a914167f3..e55a640ee561a62b6255cc7002fd49f3a956151f 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for net-news/blam
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-news/blam/ChangeLog,v 1.35 2006/11/28 14:26:19 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/blam/ChangeLog,v 1.36 2006/12/15 03:56:36 latexer Exp $
+
+*blam-1.8.4_pre2 (15 Dec 2006)
+
+  15 Dec 2006; Peter Johanson <latexer@gentoo.org>
+  +files/blam-1.8.4_pre2-gtk-sharp-2.10-compat.diff,
+  +files/blam-1.8.4_pre2-remove-funky-non-printable.diff,
+  -blam-1.8.2.ebuild, -blam-1.8.2-r1.ebuild, +blam-1.8.4_pre2.ebuild:
+  Bump to new release that uses gtk# 2, and do some cleanup.
 
   28 Nov 2006; Christian Faulhammer <opfer@gentoo.org> blam-1.8.2-r2.ebuild:
   stable x86, bug #153308
diff --git a/net-news/blam/blam-1.8.4_pre2.ebuild b/net-news/blam/blam-1.8.4_pre2.ebuild
new file mode 100644 (file)
index 0000000..7ecd3d2
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-news/blam/blam-1.8.4_pre2.ebuild,v 1.1 2006/12/15 03:56:36 latexer Exp $
+
+inherit mono eutils autotools
+
+MY_P=${P/_/}
+
+DESCRIPTION="A RSS aggregator written in C#"
+HOMEPAGE="http://www.cmartin.tk/blam.html"
+SRC_URI="http://www.cmartin.tk/blam/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+DEPEND=">=dev-lang/mono-1.1.4
+               >=dev-dotnet/gtk-sharp-2.4
+               >=dev-dotnet/gtk-sharp-2.4
+               >=dev-dotnet/gconf-sharp-2.4
+               >=dev-dotnet/glade-sharp-2.4
+               >=dev-dotnet/gecko-sharp-0.11-r1
+               >=gnome-base/gconf-2.4"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+       unpack ${A}
+       cd ${S}
+
+       if [ $(get_libdir) != "lib" ] ; then
+               sed -i -e 's:$(prefix)/lib/blam:$(libdir)/blam:' \
+                       -e "s:@prefix@/lib:@prefix@/$(get_libdir):" \
+                       ${S}/{,lib,libblam,src}/Makefile.{in,am} ${S}/blam.in || die
+       fi
+
+       # Fix for working with new mono versions
+       epatch ${FILESDIR}/${P}-remove-funky-non-printable.diff
+
+       # Fix to disambiguate some print stuff found in both
+       # gtk-sharp and gnome-sharp in 2.10/2.16
+       epatch ${FILESDIR}/${P}-gtk-sharp-2.10-compat.diff
+
+       eautomake
+}
+
+src_compile() {
+       econf || die
+       emake -j1 || die
+}
+
+src_install() {
+       make DESTDIR=${D} install || die
+       dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+}
diff --git a/net-news/blam/files/blam-1.8.4_pre2-gtk-sharp-2.10-compat.diff b/net-news/blam/files/blam-1.8.4_pre2-gtk-sharp-2.10-compat.diff
new file mode 100644 (file)
index 0000000..6fbc81e
--- /dev/null
@@ -0,0 +1,30 @@
+diff -aur blam-1.8.4pre2-orig/src/Printing.cs blam-1.8.4pre2/src/Printing.cs
+--- blam-1.8.4pre2-orig/src/Printing.cs        2006-12-02 03:29:23.000000000 -0800
++++ blam-1.8.4pre2/src/Printing.cs     2006-12-14 19:31:19.000000000 -0800
+@@ -14,7 +14,7 @@
+ namespace Imendio.Blam {
+     public class PrintDialog {
+       private ItemView itemView;
+-      private PrintJob printJob;
++      private Gnome.PrintJob printJob;
+       private static string printConfigFile = Application.BaseDir + "/print-config";
+@@ -31,7 +31,7 @@
+               return;
+           }
+           
+-          printJob = new PrintJob(LoadPrintConfig());
++          printJob = new Gnome.PrintJob(LoadPrintConfig());
+           Gnome.PrintDialog dialog = new Gnome.PrintDialog(printJob,
+                                                            "Print - " + itemView.Widget.Title);
+           dialog.Icon = Gdk.Pixbuf.LoadFromResource("blam.png");
+@@ -51,7 +51,7 @@
+               printJob.Print();
+               break;
+           case ((int)PrintButtons.Preview):
+-              PrintJobPreview preview = new PrintJobPreview(printJob,
++              Gnome.PrintJobPreview preview = new Gnome.PrintJobPreview(printJob,
+                                                             itemView.Widget.Title);
+               preview.Icon = Gdk.Pixbuf.LoadFromResource("blam.png");
+               preview.Show();
diff --git a/net-news/blam/files/blam-1.8.4_pre2-remove-funky-non-printable.diff b/net-news/blam/files/blam-1.8.4_pre2-remove-funky-non-printable.diff
new file mode 100644 (file)
index 0000000..1c88126
--- /dev/null
@@ -0,0 +1,12 @@
+diff -aur blam-1.8.4pre2-orig/src/PreferencesDialog.cs blam-1.8.4pre2/src/PreferencesDialog.cs
+--- blam-1.8.4pre2-orig/src/PreferencesDialog.cs       2006-12-02 03:29:23.000000000 -0800
++++ blam-1.8.4pre2/src/PreferencesDialog.cs    2006-12-14 19:22:36.000000000 -0800
+@@ -29,7 +29,7 @@
+         [Widget] Gtk.Label       boldBehaviourLabel        = null;
+         [Widget] Gtk.CheckButton reverseEntriesCheckButton = null;
+         [Widget] Gtk.CheckButton autoRefreshCheckButton    = null;
+-        [Widget] Gtk.CheckButton ignoreSSLErr              = null;
++        [Widget] Gtk.CheckButton ignoreSSLErr              = null;
+         [Widget] Gtk.SpinButton  refreshRateSpinButton     = null;
+         [Widget] Gtk.Label       boldThemeLabel            = null;
+         [Widget] Gtk.ComboBox  themeComboBox             = null;
diff --git a/net-news/blam/files/digest-blam-1.8.4_pre2 b/net-news/blam/files/digest-blam-1.8.4_pre2
new file mode 100644 (file)
index 0000000..0f8be0c
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 be83aace186e6196261bbafca73c4e99 blam-1.8.4pre2.tar.gz 748770
+RMD160 4bb6696d9381800845f31c5fe01870692c0d6152 blam-1.8.4pre2.tar.gz 748770
+SHA256 2d4f8292de62f4d672a98b60653c482884ddb59c65a97335fb2ef242536edb0e blam-1.8.4pre2.tar.gz 748770