use games_get_libdir
authorTristan Heaven <tristan@gentoo.org>
Fri, 6 Apr 2007 00:10:19 +0000 (00:10 +0000)
committerTristan Heaven <tristan@gentoo.org>
Fri, 6 Apr 2007 00:10:19 +0000 (00:10 +0000)
Package-Manager: portage-2.1.2.3

games-arcade/bub-n-bros/bub-n-bros-1.1.ebuild
games-arcade/bub-n-bros/files/bubnbros-server [deleted file]
games-arcade/frozen-bubble/frozen-bubble-2.1.0.ebuild

index 6af0d940a9c4137d4f477e33c4f7a0f7baccf1c3..d0c1572244f9f4f32e474099d58b589349268bf4 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/bub-n-bros/bub-n-bros-1.1.ebuild,v 1.11 2007/03/12 13:22:54 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/bub-n-bros/bub-n-bros-1.1.ebuild,v 1.12 2007/04/06 00:08:25 nyhm Exp $
 
 inherit games
 
@@ -16,38 +16,37 @@ IUSE=""
 DEPEND=">=dev-lang/python-2.2"
 RDEPEND=">=dev-python/pygame-1.5.5"
 
-S="${WORKDIR}/${PN}"
+S=${WORKDIR}/${PN}
 
 src_compile() {
        # Compile the "statesaver" extension module to enable the Clock bonus
-       cd ${S}/bubbob
+       cd "${S}"/bubbob
        python setup.py build_ext -i || die
 
        # Compile the extension module required for the X Window client
-       cd ${S}/display
+       cd "${S}"/display
        python setup.py build_ext -i || die
 }
 
 src_install() {
-       local dir=${GAMES_LIBDIR}/${PN}
+       local dir=$(games_get_libdir)/${PN}
 
-       exeinto ${dir}
-       doexe *.py
+       exeinto "${dir}"
+       doexe *.py || die "doexe failed"
 
-       insinto ${dir}
-       cp -r bubbob common display java ${D}/${dir}/
+       insinto "${dir}"
+       doins -r bubbob common display java || die "doins failed"
 
-       dodir ${GAMES_BINDIR}
-       dosym ${dir}/pclient-pygame.py ${GAMES_BINDIR}/bubnbros
-       dosym ${dir}/pclient-xshm.py ${GAMES_BINDIR}/bubnbros-x
-       dosym ${dir}/pclient-slow-X.py ${GAMES_BINDIR}/bubnbros-slowx
+       dodir "${GAMES_BINDIR}"
+       dosym "${dir}"/pclient-pygame.py "${GAMES_BINDIR}"/bubnbros
+       dosym "${dir}"/pclient-xshm.py "${GAMES_BINDIR}"/bubnbros-x
+       dosym "${dir}"/pclient-slow-X.py "${GAMES_BINDIR}"/bubnbros-slowx
 
-       dogamesbin ${FILESDIR}/bubnbros-server
-       dosed "s:GENTOO_DIR:${dir}/bubbob/:" ${GAMES_BINDIR}/bubnbros-server
+       games_make_wrapper bubnbros-server "python ./bb.py" "${dir}"/bubbob
 
        dohtml *.html
 
-       find ${D}/${dir} -name CVS -type d -exec rm -rf '{}' \; 2> /dev/null
+       find "${D}/${dir}" -name CVS -type d -exec rm -rf '{}' \; 2> /dev/null
 
        prepgamesdirs
 }
diff --git a/games-arcade/bub-n-bros/files/bubnbros-server b/games-arcade/bub-n-bros/files/bubnbros-server
deleted file mode 100644 (file)
index e60361f..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-cd GENTOO_DIR
-exec python bb.py $@
index 1a1f7617d54c2291756458c54076574cabd93025..c631e621f44b9a5751685713730552815203b146 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/frozen-bubble/frozen-bubble-2.1.0.ebuild,v 1.2 2007/01/13 21:33:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/frozen-bubble/frozen-bubble-2.1.0.ebuild,v 1.3 2007/04/06 00:10:19 nyhm Exp $
 
 inherit eutils multilib perl-module games
 
@@ -44,7 +44,7 @@ src_unpack() {
                -e '/^PREFIX /s:=.*:=/usr:' \
                -e "/^BINDIR /s:=.*:=${GAMES_BINDIR}:" \
                -e "/^DATADIR /s:=.*:=${GAMES_DATADIR}:" \
-               -e "/^LIBDIR /s:=.*:=${GAMES_LIBDIR}:" \
+               -e "/^LIBDIR /s:=.*:=$(games_get_libdir):" \
                -e '/^LOCALEDIR /s:=.*:=/usr/share/locale:' \
                -e "/^MANDIR /s:=.*:=/usr/share/man:" \
                settings.mk || die "sed failed"