dev-python/pymongo: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 11:38:09 +0000 (13:38 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 11:38:09 +0000 (13:38 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pymongo/Manifest
dev-python/pymongo/pymongo-3.9.0.ebuild [deleted file]

index da11990270ae8b2430569185e48b27ca2009dc10..4dc1c029ef9759c683d65271a768cd1c3d505d39 100644 (file)
@@ -1,2 +1 @@
 DIST pymongo-3.10.1.tar.gz 715892 BLAKE2B df1f8ae34366ea9de633be7e1ca103a2bc704a18a9b23cb1fbdbc8d116e939d4d5462e18a076149d93dcb8ada9f4737ed2d61b08803b546dce89dca4b2416689 SHA512 5a73ac17ef6f6783a573facd90879dbefa0c95d69123bc67c1a6af0987cb5786f637b8fa81a6810387acc34829a4cde33b848ac0f7b08f7d07faa90a8e13b595
-DIST pymongo-3.9.0.tar.gz 701117 BLAKE2B c13b53f06fa1788f65de46b6a05474355e312a1cdd7798610b300c1a7bb9964d32243da52a4dad61d5b50e736c717f5549f61b28c06e1024505bdd3ec04ab99a SHA512 3ac8831ffd82c27bfbf8429a38fe26aed177ba68b89d0ddf043adfde326b8c01eea9be449bb985421f42677fab4dd5ab44e1c1c9eeb3aff41d792c660fe23e0b
diff --git a/dev-python/pymongo/pymongo-3.9.0.ebuild b/dev-python/pymongo/pymongo-3.9.0.ebuild
deleted file mode 100644 (file)
index e144d83..0000000
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
-inherit check-reqs distutils-r1
-
-DESCRIPTION="Python driver for MongoDB"
-HOMEPAGE="https://github.com/mongodb/mongo-python-driver https://pypi.org/project/pymongo/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm64 ~hppa x86"
-IUSE="doc kerberos test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       kerberos? ( dev-python/pykerberos[${PYTHON_USEDEP}] )
-"
-DEPEND="
-       ${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? (
-               dev-python/nose[${PYTHON_USEDEP}]
-               >=dev-db/mongodb-2.6.0
-       )
-"
-DISTUTILS_IN_SOURCE_BUILD=1
-
-reqcheck() {
-       if use test; then
-               # During the tests, database size reaches 1.5G.
-               local CHECKREQS_DISK_BUILD=1536M
-
-               check-reqs_${1}
-       fi
-}
-
-pkg_pretend() {
-       reqcheck pkg_pretend
-}
-
-pkg_setup() {
-       reqcheck pkg_setup
-}
-
-python_compile_all() {
-       if use doc; then
-               mkdir html || die
-               sphinx-build doc html || die
-       fi
-}
-
-python_test() {
-       # Yes, we need TCP/IP for that...
-       local DB_IP=127.0.0.1
-       local DB_PORT=27000
-
-       export DB_IP DB_PORT
-
-       local dbpath=${TMPDIR}/mongo.db
-       local logpath=${TMPDIR}/mongod.log
-
-       # Now, the hard part: we need to find a free port for mongod.
-       # We're just trying to run it random port numbers and check the log
-       # for bind errors. It shall be noted that 'mongod --fork' does not
-       # return failure when it fails to bind.
-
-       mkdir -p "${dbpath}" || die
-       while true; do
-               ebegin "Trying to start mongod on port ${DB_PORT}"
-
-               LC_ALL=C \
-               mongod --dbpath "${dbpath}" --nojournal \
-                       --bind_ip ${DB_IP} --port ${DB_PORT} \
-                       --unixSocketPrefix "${TMPDIR}" \
-                       --logpath "${logpath}" --fork \
-               && sleep 2
-
-               # Now we need to check if the server actually started...
-               if [[ ${?} -eq 0 && -S "${TMPDIR}"/mongodb-${DB_PORT}.sock ]]; then
-                       # yay!
-                       eend 0
-                       break
-               elif grep -q 'Address already in use' "${logpath}"; then
-                       # ay, someone took our port!
-                       eend 1
-                       : $(( DB_PORT += 1 ))
-                       continue
-               else
-                       eend 1
-                       eerror "Unable to start mongod for tests. See the server log:"
-                       eerror "        ${logpath}"
-                       die "Unable to start mongod for tests."
-               fi
-       done
-
-       local failed
-       #https://jira.mongodb.org/browse/PYTHON-521, py2.[6-7] has intermittent failure with gevent
-       pushd "${BUILD_DIR}"/../ > /dev/null
-       if [[ "${EPYTHON}" == python3* ]]; then
-               2to3 --no-diffs -w test
-       fi
-       DB_PORT2=$(( DB_PORT + 1 )) DB_PORT3=$(( DB_PORT + 2 )) esetup.py test || failed=1
-
-       mongod --dbpath "${dbpath}" --shutdown || die
-
-       [[ ${failed} ]] && die "Tests fail with ${EPYTHON}"
-
-       rm -rf "${dbpath}" || die
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( html/. )
-
-       distutils-r1_python_install_all
-}