dev-python/entrypoints: Version bump to 0.2.2
authorMarius Brehler <marbre@linux.sungazer.de>
Wed, 8 Mar 2017 17:47:01 +0000 (18:47 +0100)
committerDavid Seifert <soap@gentoo.org>
Thu, 9 Mar 2017 20:43:59 +0000 (21:43 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Closes: https://github.com/gentoo/gentoo/pull/4164

dev-python/entrypoints/Manifest
dev-python/entrypoints/entrypoints-0.2.2.ebuild [new file with mode: 0644]
dev-python/entrypoints/files/entrypoints-0.2.2-setup.py.patch [new file with mode: 0644]

index 8ba52629a38735c6cfab82bae1296e2a412ae0c9..04d735e50c6b0f917a643a6b849078c2373dff9d 100644 (file)
@@ -1 +1,2 @@
 DIST entrypoints-0.2.1.tar.gz 11126 SHA256 0d6b6798446c2e5e5dd6691e79356c29e82234bdb67995233f57413a11f2ded4 SHA512 67a24fc53ae8bdac6bda163d2c8057b158979d55ccdbcdb8709966573bf0a999728e04eb92a05fbc2c0d532593de0ec6518bcfed1d5bcf875b00bbd5c48494c7 WHIRLPOOL f673fb42bad930bb1907692013df469d64b9afb77c3e0acca250fb0b14fe17ec3962cb60de2f0760ede40c8f039690851424b816e047669916ff1d73389daaf7
+DIST entrypoints-0.2.2.tar.gz 11162 SHA256 e54b5df8bb971507278c65df96e6486cf4aea0cdac384d0102ea0339e0a4f82b SHA512 c987807924f92fd6bc0aab1cccaa4b204587d4f34932c353033ed062fff5adf69bfdc8767f095dda15fff9b57e2be2d205bfa44abc5ad7f7820114e0355a6e99 WHIRLPOOL 9d884c8977f8ea49f23f3c8a6b8ac3d48de6e6ff1133f53afe7072e180fd714019c9076b553deae5595d2383a02728412a8536ea26f4a1a56a8d552806054da9
diff --git a/dev-python/entrypoints/entrypoints-0.2.2.ebuild b/dev-python/entrypoints/entrypoints-0.2.2.ebuild
new file mode 100644 (file)
index 0000000..1d04d23
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Discover and load entry points from installed packages"
+HOMEPAGE="https://github.com/takluyver/entrypoints"
+SRC_URI="https://github.com//takluyver/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+       $(python_gen_cond_dep '>=dev-python/configparser-3.5.0[${PYTHON_USEDEP}]' 'python2*')
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+               virtual/python-pathlib[${PYTHON_USEDEP}]
+       )
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+       "
+
+PATCHES=(
+       "${FILESDIR}/${P}"-setup.py.patch
+       "${FILESDIR}/${PN}"-0.2.1-init.py.patch
+)
+
+python_prepare_all() {
+       # Prevent un-needed download during build
+       if use doc; then
+               sed -e "/^    'sphinx.ext.intersphinx',/d" -i doc/conf.py || die
+       fi
+
+       distutils-r1_python_prepare_all
+
+       mv "${WORKDIR}/${P}"/entrypoints.py "${WORKDIR}/${P}/${PN}/" || die
+}
+
+python_compile_all() {
+       if use doc; then
+               emake -C doc html
+               HTML_DOCS=( doc/_build/html/. )
+       fi
+}
+
+python_test() {
+       distutils_install_for_testing
+       cd "${TEST_DIR}"/lib || die
+       cp -r "${S}"/tests "${TEST_DIR}"/lib/ || die
+       py.test || die
+}
diff --git a/dev-python/entrypoints/files/entrypoints-0.2.2-setup.py.patch b/dev-python/entrypoints/files/entrypoints-0.2.2-setup.py.patch
new file mode 100644 (file)
index 0000000..bb82eee
--- /dev/null
@@ -0,0 +1,20 @@
+setup.py for entrypoints by Marius Brehler <marbre@linux.sungazer.de>.
+
+Patch by Marius Brehler <marbrbre@linux.sungazer.de>.
+--- /dev/null
++++ b/setup.py
+@@ -0,0 +1,13 @@
++from distutils.core import setup
++
++setup(name='entrypoints',
++      version='0.2.2',
++      description='Discover and load entry points from installed packages.',
++      author='Thomas Kluyver',
++      author_email='thomas@kluyver.me.uk',
++      url='https://github.com/takluyver/entrypoints',
++      packages=['entrypoints'],
++      classifiers=[
++          'License :: OSI Approved :: MIT License'
++      ]
++)
+\ No newline at end of file