dev-ros/gazebo_plugins: Bump to 2.6.2.
authorAlexis Ballier <aballier@gentoo.org>
Tue, 21 Feb 2017 08:06:31 +0000 (09:06 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 21 Feb 2017 09:21:11 +0000 (10:21 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-ros/gazebo_plugins/Manifest
dev-ros/gazebo_plugins/gazebo_plugins-2.6.2.ebuild [new file with mode: 0644]

index 28579f9b6847fc1f328befbcab9b8908ceae9ae3..134a4b92f74fcb4073df866b975d8317d0c96a3e 100644 (file)
@@ -1 +1,2 @@
 DIST gazebo_ros_pkgs-2.6.1.tar.gz 1825040 SHA256 18b987af9e8e6a59232af8313675bb05f9db39e5c4701459912f996d8c0858b3 SHA512 4cc0b2ec5c60e69b9a69d323c2c7cfe53bc1b5108d6cba5d77b571c69d76a7eb6d72a3783dc60fe183057c63279df8d5cded26cd46333e9f21277e9ae1e31c34 WHIRLPOOL 47510176a89d21144a41aa48e5dfe9bce38fcb5674f1fe157fd4bd0909091cb57eb7ce89e3f39236d5f0960a8a2f1093578de1b9c86626c41e2eccb84e18ec67
+DIST gazebo_ros_pkgs-2.6.2.tar.gz 1830633 SHA256 48f1b1878819a424147195e0b3fa010aaf7b5f7a40ffef522c153f1adc6d3ae0 SHA512 f932eebbc88f4922c0275625d50ad5723446744cbf4a59138437d9bdd75a9b5232fdf8df2012460313eb2224d4287daebc3a28181ab3f1b81e67d70a8b8ed5d3 WHIRLPOOL aa13810a8fbcde4de2c078c89542285cda61f47228bfbe2b237027a920ea5a01ccd823fd1d87d37923202d3a8b88a9017eccc44f1359da32a57cea23489a9948
diff --git a/dev-ros/gazebo_plugins/gazebo_plugins-2.6.2.ebuild b/dev-ros/gazebo_plugins/gazebo_plugins-2.6.2.ebuild
new file mode 100644 (file)
index 0000000..ab8d4d4
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Robot-independent Gazebo plugins for sensors, motors and dynamic reconfigurable components"
+LICENSE="BSD Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/gazebo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/roscpp
+       dev-ros/rospy
+       dev-ros/nodelet
+       dev-ros/angles
+       dev-ros/std_srvs
+       dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+       dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/urdf
+       dev-ros/tf
+       dev-ros/tf2_ros
+       dev-ros/dynamic_reconfigure
+       dev-ros/driver_base
+       dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/trajectory_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/pcl_conversions
+       dev-ros/image_transport
+       dev-ros/rosconsole
+       dev-ros/cv_bridge
+       dev-ros/polled_camera
+       dev-ros/diagnostic_updater
+       dev-ros/camera_info_manager
+       dev-ros/moveit_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-libs/libxml2
+       >=sci-electronics/gazebo-7:=
+       dev-games/ogre
+       sci-libs/pcl
+       dev-libs/boost:=
+       dev-qt/qtcore:4
+       dev-qt/qtgui:4
+       dev-ros/roslib[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"