dev-python/pillow: Version Bump
authorJustin Lecher <jlec@gentoo.org>
Fri, 2 Oct 2015 09:08:56 +0000 (11:08 +0200)
committerJustin Lecher <jlec@gentoo.org>
Fri, 2 Oct 2015 09:41:19 +0000 (11:41 +0200)
Package-Manager: portage-2.2.22
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/pillow/Manifest
dev-python/pillow/files/pillow-3.0.0-tests.patch [new file with mode: 0644]
dev-python/pillow/pillow-3.0.0.ebuild [new file with mode: 0644]

index 441f129ea311f95d9cae229cd8f540b22ac90057..6d875aee4c4c0066e65247bf1e323684ba822824 100644 (file)
@@ -1,3 +1,4 @@
 DIST Pillow-2.8.1.zip 9275663 SHA256 4363b52527c263e77f5b18c3dfffd15ae454edf0c4457197ecbe29863a651938 SHA512 75c0cfb53530549a2bac66cc3457747c239779233c64fe944fa661e7401acd915700e0dfd74e13c93d96afb9b50a112f09cbaea49205e83d8797e832a52534e4 WHIRLPOOL e71a39be415c2b83b7d554af7ad86652c08594c302344c919352a64ca48cfc7c1a88ca8dacccdacb283d8a42ad14cd3cb230c2900a9f11dc31ad20e203d6596d
 DIST Pillow-2.8.2.zip 9402887 SHA256 57a900c2f30e53ed054adad401ab69643d9ab21e3acb0a647749a168e4e24446 SHA512 2bc1e17cb65d5e953e30ea1606dbf79059d51f60ff5c2b000869fc2d9f93f8bbf5cf41b0147fc83974c48341cc68df6964d3d8203e0d6cc6a45ede95f3e0bc2f WHIRLPOOL 4b5ad1db34427a161ce1885a858df72e4aaffd61b5bf9010702803874f44391678d228f71777fca058f424c6ac6208e8c3d7421eeff88c42bb6df94d1d13d771
 DIST Pillow-2.9.0.zip 9612840 SHA256 d1db8dfed77547076037d589b598e04f2cbc1a7835d3d3f137bf20c8994854d5 SHA512 d06371fbe67eca66229cdec7896423f55c9335be50698168c7bf4f4635352454b2f946eae90b404c68d6b939ec1d7353916d32bc9964d5b8986b8098381d5180 WHIRLPOOL c664fec07c6634cad37791375fb1cb38b0edd542d93e099703dbc520e0d54125a1f00f205bbcdb8493df4dfd05ae1c2088ba305f23e66f0cc3e309f446c44fa5
+DIST Pillow-3.0.0.zip 9947593 SHA256 0024fce578547a3da92579a163bae09b1d9f0baf3cd8e4a893dc6c11e4e624bb SHA512 59dd809160743d2740dfe64743dc674bb4cb6395914048d0d555ccacc7fee1c8f3a114ec39142b5495a0162a74acaadf7ad66694f97c7f221ccffe19cd656928 WHIRLPOOL 0fe2c9af2557278cc855ec7ddb4cfd944fbd1fc3cb2a614e84bd1dfa0c8ba243e60bda863b0b254098bcc7510d62953dbccf1fce88996011327f1059df0b69fb
diff --git a/dev-python/pillow/files/pillow-3.0.0-tests.patch b/dev-python/pillow/files/pillow-3.0.0-tests.patch
new file mode 100644 (file)
index 0000000..b2228ea
--- /dev/null
@@ -0,0 +1,63 @@
+ Tests/test_imagefont.py | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/Tests/test_imagefont.py b/Tests/test_imagefont.py
+index dd22344..d0a0826 100644
+--- a/Tests/test_imagefont.py
++++ b/Tests/test_imagefont.py
+@@ -112,6 +112,7 @@ try:
+             self.assert_image_equal(img_path, img_filelike)
+             self._clean()
++        @unittest.skip("https://github.com/python-pillow/Pillow/issues/1259")
+         def test_textsize_equal(self):
+             im = Image.new(mode='RGB', size=(300, 100))
+             draw = ImageDraw.Draw(im)
+@@ -126,6 +127,7 @@ try:
+             target_img = Image.open(target)
+             self.assert_image_similar(im, target_img, .5)
++        @unittest.skip("https://github.com/python-pillow/Pillow/issues/1259")
+         def test_render_multiline(self):
+             im = Image.new(mode='RGB', size=(300, 100))
+             draw = ImageDraw.Draw(im)
+@@ -145,6 +147,7 @@ try:
+             # at epsilon = ~38.
+             self.assert_image_similar(im, target_img, .5)
++        @unittest.skip("https://github.com/python-pillow/Pillow/issues/1259")
+         def test_render_multiline_text(self):
+             ttf = ImageFont.truetype(FONT_PATH, FONT_SIZE)
+@@ -200,6 +203,7 @@ try:
+                              draw.multiline_textsize("longest line\nline",
+                                                      font=ttf)[0])
++        @unittest.skip("https://github.com/python-pillow/Pillow/issues/1259")
+         def test_multiline_spacing(self):
+             ttf = ImageFont.truetype(FONT_PATH, FONT_SIZE)
+@@ -255,6 +259,7 @@ try:
+             # Check boxes a and b are same size
+             self.assertEqual(box_size_a, box_size_b)
++        @unittest.skip("https://github.com/python-pillow/Pillow/issues/1456")
+         def test_rotated_transposed_font_get_mask(self):
+             # Arrange
+             text = "mask this"
+@@ -269,6 +274,7 @@ try:
+             # Assert
+             self.assertEqual(mask.size, (13, 108))
++        @unittest.skip("https://github.com/python-pillow/Pillow/issues/1456")
+         def test_unrotated_transposed_font_get_mask(self):
+             # Arrange
+             text = "mask this"
+@@ -316,6 +322,7 @@ try:
+             # Assert
+             self.assertEqual(offset, (0, 3))
++        @unittest.skip("https://github.com/python-pillow/Pillow/issues/1456")
+         def test_free_type_font_get_mask(self):
+             # Arrange
+             font = ImageFont.truetype(FONT_PATH, FONT_SIZE)
diff --git a/dev-python/pillow/pillow-3.0.0.ebuild b/dev-python/pillow/pillow-3.0.0.ebuild
new file mode 100644 (file)
index 0000000..511398d
--- /dev/null
@@ -0,0 +1,93 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+PYTHON_REQ_USE='tk?'
+
+inherit distutils-r1 eutils virtualx
+
+MY_PN=Pillow
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python Imaging Library (fork)"
+HOMEPAGE="https://github.com/python-imaging/Pillow https://pypi.python.org/pypi/Pillow"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="doc examples jpeg jpeg2k lcms test tiff tk truetype webp zlib"
+
+REQUIRED_USE="test? ( jpeg tiff )"
+
+RDEPEND="
+       jpeg? ( virtual/jpeg:0 )
+       jpeg2k? ( media-libs/openjpeg:2= )
+       lcms? ( media-libs/lcms:2= )
+       tiff? ( media-libs/tiff:0= )
+       truetype? ( media-libs/freetype:2= )
+       webp? ( media-libs/libwebp:0= )
+       zlib? ( sys-libs/zlib:0= )"
+DEPEND="${RDEPEND}
+       app-arch/unzip
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? (
+               dev-python/sphinx[${PYTHON_USEDEP}]
+               dev-python/sphinx-better-theme[${PYTHON_USEDEP}]
+               >=dev-python/sphinx_rtd_theme-0.1[${PYTHON_USEDEP}]
+               <dev-python/sphinx_rtd_theme-0.2[${PYTHON_USEDEP}]
+       )
+       test? ( dev-python/nose[${PYTHON_USEDEP}] )
+       "
+RDEPEND+=" !dev-python/imaging"
+
+S="${WORKDIR}/${MY_P}"
+
+# See _render and _clean in Tests/test_imagefont.py
+DISTUTILS_IN_SOURCE_BUILD=1
+
+PATCHES=( "${FILESDIR}"/${P}-tests.patch )
+
+python_prepare_all() {
+       # Disable all the stuff we don't want.
+       local f
+       for f in jpeg lcms tiff tk webp zlib; do
+               if ! use ${f}; then
+                       sed -i -e "s:feature.${f} =:& None #:" setup.py || die
+               fi
+       done
+       if ! use truetype; then
+               sed -i -e 's:feature.freetype =:& None #:' setup.py || die
+       fi
+       if ! use jpeg2k; then
+               sed -i -e 's:feature.jpeg2000 =:& None #:' setup.py || die
+       fi
+
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       use doc && emake -C docs html
+}
+
+python_test() {
+       "${PYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
+       VIRTUALX_COMMAND=nosetests
+       virtualmake -vx Tests/test_*.py || die "Testing failed with ${EPYTHON}"
+}
+
+python_install() {
+       python_doheader libImaging/{Imaging.h,ImPlatform.h}
+
+       distutils-r1_python_install
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( docs/_build/html/. )
+       use examples && local EXAMPLES=( Scripts/. )
+
+       distutils-r1_python_install_all
+}