add patch from Sander Sweers to support building against newer miniupnpc (bug #562046)
authorMichael Sterrett <mr_bones_@gentoo.org>
Mon, 5 Oct 2015 00:44:52 +0000 (20:44 -0400)
committerMichael Sterrett <mr_bones_@gentoo.org>
Mon, 5 Oct 2015 00:47:23 +0000 (20:47 -0400)
Package-Manager: portage-2.2.20.1

games-strategy/megaglest/files/megaglest-3.11.1-miniupnpc.patch [new file with mode: 0644]
games-strategy/megaglest/megaglest-3.11.1.ebuild

diff --git a/games-strategy/megaglest/files/megaglest-3.11.1-miniupnpc.patch b/games-strategy/megaglest/files/megaglest-3.11.1-miniupnpc.patch
new file mode 100644 (file)
index 0000000..112e734
--- /dev/null
@@ -0,0 +1,21 @@
+diff --git a/source/shared_lib/sources/platform/posix/socket.cpp b/source/shared_lib/sources/platform/posix/socket.cpp
+index a5d4b92..cb8ceb4 100644
+--- a/source/shared_lib/sources/platform/posix/socket.cpp
++++ b/source/shared_lib/sources/platform/posix/socket.cpp
+@@ -2563,9 +2563,15 @@ int UPNP_Tools::upnp_init(void *param) {
+               const char *upnp_minissdpdsock = NULL;
+               int upnp_sameport = 0;
+               int upnp_ipv6 = 0;
++              unsigned char upnp_ttl = 2;
+               int upnp_error = 0;
+-#ifndef MINIUPNPC_VERSION_PRE1_6
++#if (MINIUPNPC_API_VERSION >= 14)
++              devlist = upnpDiscover(upnp_delay, upnp_multicastif, upnp_minissdpdsock, upnp_sameport, upnp_ipv6, upnp_ttl, &upnp_error);
++
++              if(SystemFlags::getSystemSettingType(SystemFlags::debugNetwork).enabled) SystemFlags::OutputDebug(SystemFlags::debugNetwork,"UPnP discover returned upnp_error = %d.\n",upnp_error);
++              if(SystemFlags::VERBOSE_MODE_ENABLED) printf("UPnP discover returned upnp_error = %d.\n",upnp_error);
++#elif (MINIUPNPC_API_VERSION >= 8)
+               devlist = upnpDiscover(upnp_delay, upnp_multicastif, upnp_minissdpdsock, upnp_sameport, upnp_ipv6, &upnp_error);
+               if(SystemFlags::getSystemSettingType(SystemFlags::debugNetwork).enabled) SystemFlags::OutputDebug(SystemFlags::debugNetwork,"UPnP discover returned upnp_error = %d.\n",upnp_error);
index 7776e566b51f15c290d6f3debfa546c66a3793cc..3c74a8d381b99940e114baf3e06c1eccd13558f0 100644 (file)
@@ -71,7 +71,8 @@ src_prepare() {
        fi
 
        epatch "${FILESDIR}"/${P}-static-build.patch \
-               "${FILESDIR}"/${P}-cmake.patch
+               "${FILESDIR}"/${P}-cmake.patch \
+               "${FILESDIR}"/${P}-miniupnpc.patch
 }
 
 src_configure() {