sys-boot/grub: call eautoreconf for the sysmacros patch
authorMike Gilbert <floppym@gentoo.org>
Wed, 27 Apr 2016 16:20:25 +0000 (12:20 -0400)
committerMike Gilbert <floppym@gentoo.org>
Wed, 27 Apr 2016 16:20:39 +0000 (12:20 -0400)
Package-Manager: portage-2.2.28_p79

sys-boot/grub/grub-2.02_beta3-r1.ebuild

index 43291a0473bdc025dcec1ab7982daa6399cc3e97..99531f1d3e5d433279118c3c9c91a79bb8baf12d 100644 (file)
@@ -6,7 +6,7 @@ EAPI=6
 
 if [[ ${PV} == 9999  ]]; then
        PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
-       inherit autotools python-any-r1
+       inherit python-any-r1
 fi
 
 inherit autotools bash-completion-r1 flag-o-matic multibuild pax-utils toolchain-funcs versionator
@@ -150,12 +150,8 @@ src_prepare() {
                sed -i -e 's/^\* GRUB:/* GRUB2:/' -e 's/(grub)/(grub2)/' docs/grub.texi || die
        fi
 
-       if [[ ${PV} == 9999 ]]; then
-               python_setup
-               bash autogen.sh || die
-               autopoint() { :; }
-               eautoreconf
-       fi
+       autopoint() { :; }
+       eautoreconf
 }
 
 grub_do() {