dev-ruby/file-tail: avoid test with race condition
authorHans de Graaff <graaff@gentoo.org>
Sat, 23 May 2020 09:13:31 +0000 (11:13 +0200)
committerHans de Graaff <graaff@gentoo.org>
Sat, 23 May 2020 09:13:58 +0000 (11:13 +0200)
Closes: https://bugs.gentoo.org/723822
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
dev-ruby/file-tail/file-tail-1.2.0.ebuild

index 2a1cd8f29230bd401717643412f717b44d787ffd..4d1d4ec10c74fde24bfe3b75f09911b11f9f67bb 100644 (file)
@@ -27,6 +27,10 @@ IUSE=""
 ruby_add_rdepend "=dev-ruby/tins-1*"
 ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
 
+all_ruby_prepare() {
+       sed -i -e '/test_tail_change2/aomit "has race condition"' tests/file_tail_test.rb || die
+}
+
 each_ruby_test() {
        ruby-ng_testrb-2 -Ilib tests/*_test.rb