dev-ros/pr2_msgs: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Wed, 23 Sep 2015 10:41:41 +0000 (12:41 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 23 Sep 2015 10:41:41 +0000 (12:41 +0200)
Package-Manager: portage-2.2.21

dev-ros/pr2_msgs/Manifest [new file with mode: 0644]
dev-ros/pr2_msgs/metadata.xml [new file with mode: 0644]
dev-ros/pr2_msgs/pr2_msgs-1.11.9.ebuild [new file with mode: 0644]
dev-ros/pr2_msgs/pr2_msgs-9999.ebuild [new file with mode: 0644]

diff --git a/dev-ros/pr2_msgs/Manifest b/dev-ros/pr2_msgs/Manifest
new file mode 100644 (file)
index 0000000..81a1f40
--- /dev/null
@@ -0,0 +1 @@
+DIST pr2_common-1.11.9.tar.gz 33337556 SHA256 c6134939602c8a81d006bf4a4bfc48bf8746f5eb0c5b12baa1da8c946d1b4ce1 SHA512 44eb4f802a7b6983b621ca5b2c1c0e2516f16992f35902c2fb4afbdc9ffc8e63c1ed647f4ef09fd4cbeef747aba133a55172cec64c3cf9d759d2c83f7ec8a213 WHIRLPOOL ad5d6c543b1faca2ed48a66405eb8d6c17b9ef6352fa16b6fc55f9b093a6b1b7da3e0571ade5a6013c84d3695c16e910549ea2673c36a4179043ea4f085c1e05
diff --git a/dev-ros/pr2_msgs/metadata.xml b/dev-ros/pr2_msgs/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/pr2_msgs/pr2_msgs-1.11.9.ebuild b/dev-ros/pr2_msgs/pr2_msgs-1.11.9.ebuild
new file mode 100644 (file)
index 0000000..b296b46
--- /dev/null
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/pr2/pr2_common"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Messages for representing PR2 state, such as battery information and the PR2 fingertip sensors"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/pr2_msgs/pr2_msgs-9999.ebuild b/dev-ros/pr2_msgs/pr2_msgs-9999.ebuild
new file mode 100644 (file)
index 0000000..b296b46
--- /dev/null
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/pr2/pr2_common"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Messages for representing PR2 state, such as battery information and the PR2 fingertip sensors"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"